have the problem with mydns on CentOS 5.3 x86_64

Discussion in 'Installation/Configuration' started by thaibinhtt, May 25, 2009.

  1. thaibinhtt

    thaibinhtt New Member

    Hello everybody,

    I setup my box running CentOS 5.3 x86_64 using tutorial ISPConfig 3 on CentOS 5.2 at link http://www.howtoforge.com/perfect-server-centos-5.2-ispconfig-3

    I have no problem when finishing my setup.

    Code:
    "lib/install.lib.php" 586L, 14929C written
    [[email protected] install]# php -q install.php 
    
    
    --------------------------------------------------------------------------------
     _____ ___________   _____              __ _       
    |_   _/  ___| ___ \ /  __ \            / _(_)      
      | | \ `--.| |_/ / | /  \/ ___  _ __ | |_ _  __ _ 
      | |  `--. \  __/  | |    / _ \| '_ \|  _| |/ _` |
     _| |_/\__/ / |     | \__/\ (_) | | | | | | | (_| |
     \___/\____/\_|      \____/\___/|_| |_|_| |_|\__, |
                                                  __/ |
                                                 |___/ 
    --------------------------------------------------------------------------------
    
    
    >> Initial configuration  
    
    Operating System: CentOS 5.3 or compatible
    
        Following will be a few questions for primary configuration so be careful.
        Default values are in [brackets] and can be accepted with <ENTER>.
        Tap in "quit" (without the quotes) to stop the installer.
    
    
    Select language (en,de) [en]: 
    
    Installation mode (standard,expert) [standard]: 
    
    Full qualified hostname (FQDN) of the server, eg server1.domain.tld  [server1.uranus.vn]: 
    
    MySQL server hostname [localhost]: 
    
    MySQL root username [root]: 123456
    
    MySQL root password []: 
    [[email protected] install]# php -q install.php 
    
    
    --------------------------------------------------------------------------------
     _____ ___________   _____              __ _       
    |_   _/  ___| ___ \ /  __ \            / _(_)      
      | | \ `--.| |_/ / | /  \/ ___  _ __ | |_ _  __ _ 
      | |  `--. \  __/  | |    / _ \| '_ \|  _| |/ _` |
     _| |_/\__/ / |     | \__/\ (_) | | | | | | | (_| |
     \___/\____/\_|      \____/\___/|_| |_|_| |_|\__, |
                                                  __/ |
                                                 |___/ 
    --------------------------------------------------------------------------------
    
    
    >> Initial configuration  
    
    Operating System: CentOS 5.3 or compatible
    
        Following will be a few questions for primary configuration so be careful.
        Default values are in [brackets] and can be accepted with <ENTER>.
        Tap in "quit" (without the quotes) to stop the installer.
    
    
    Select language (en,de) [en]: 
    
    Installation mode (standard,expert) [standard]: 
    
    Full qualified hostname (FQDN) of the server, eg server1.domain.tld  [server1.uranus.vn]: 
    
    MySQL server hostname [localhost]: 
    
    MySQL root username [root]: 
    
    MySQL root password []: 123456
    
    MySQL database to create [dbispconfig]: 
    
    MySQL charset [utf8]: 
    
    Generating a 2048 bit RSA private key
    ...................................................................................+++
    ............................+++
    writing new private key to 'smtpd.key'
    -----
    You are about to be asked to enter information that will be incorporated
    into your certificate request.
    What you are about to enter is what is called a Distinguished Name or a DN.
    There are quite a few fields but you can leave some blank
    For some fields there will be a default value,
    If you enter '.', the field will be left blank.
    -----
    Country Name (2 letter code) [GB]:
    State or Province Name (full name) [Berkshire]:
    Locality Name (eg, city) [Newbury]:
    Organization Name (eg, company) [My Company Ltd]:
    Organizational Unit Name (eg, section) []:
    Common Name (eg, your name or your server's hostname) []:
    Email Address []:
    Configuring Jailkit
    Configuring SASL
    Configuring PAM
    Configuring Courier
    Configuring Spamassassin
    Configuring Amavisd
    Configuring Getmail
    Configuring Pureftpd
    Configuring MyDNS
    Configuring Apache
    Configuring Firewall
    Installing ISPConfig
    ISPConfig Port [8080]: 
    
    Configuring DBServer
    Installing Crontab
    no crontab for root
    no crontab for getmail
    Restarting services ...
    Stopping MySQL:  [  OK  ]
    Starting MySQL:  [  OK  ]
    Shutting down postfix: [  OK  ]
    Starting postfix: [  OK  ]
    Stopping saslauthd: [  OK  ]
    Starting saslauthd: [  OK  ]
    Shutting down Mail Virus Scanner (amavisd): [  OK  ]
    Starting Mail Virus Scanner (amavisd): [  OK  ]
    Stopping Clam AntiVirus Daemon: [  OK  ]
    Starting Clam AntiVirus Daemon: [  OK  ]
    Stopping Courier authentication services: authdaemond
    Starting Courier authentication services: authdaemond
    Stopping Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
    Starting Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
    Stopping httpd: [  OK  ]
    [Sun May 17 08:36:54 2009] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Sun May 17 08:36:54 2009] [warn] NameVirtualHost *:80 has no VirtualHosts
    Starting httpd: [  OK  ]
    Stopping pure-ftpd: [  OK  ]
    Starting pure-ftpd: [  OK  ]
    Installation completed.
    [[email protected] install]# 
    Although Installation completed, but I have the problem with mydns, it don't resolve any domains on Internet.

    Code:
    [email protected] ~]# netstat -tap | grep mydns
    getnameinfo failed
    getnameinfo failed
    tcp        0      0 server1.uranus.vn:domain    *:*                         LISTEN      2563/mydns          
    tcp        0      0 localhost.localdomai:domain *:*                         LISTEN      2563/mydns          
    tcp        0      0 localhost6.localdoma:domain *:*                         LISTEN      2563/mydns          
    [[email protected] ~]# nslookup
    > www.learnit.vn
    Server:         192.168.1.200
    Address:        192.168.1.200#53
    
    Name:   www.learnit.vn
    Address: 192.168.1.200
    > google.com
    Server:         192.168.1.200
    Address:        192.168.1.200#53
    
    ** server can't find google.com: REFUSED
    > 
    
    
    Noted, a www.learnit.vn is record in table dns_rr.

    And bellow it is mydns.config

    Code:
    ## AUTOMATICALLY GENERATED BY DEBCONF. DO NOT MODIFY DATABASE
    ## INFORMATION (database, db-*)...
    ## PLEASE RUN 'dpkg-reconfigure mydns-mysql' INSTEAD.
    ## CHANGES TO THE FOLLOWING DIRECTIVES ARE NOT PRESERVED, BUT REPLACED,
    ## ON UPGRADE:
    ##  user, group, pidfile, db-*, database
    
    ##
    ##  /etc/mydns.conf
    ##  Thu Aug  2 16:36:26 2007
    ##  For more information, see mydns.conf(5).
    ##
    
    
                                    # DATABASE INFORMATION
    
    db-host = localhost             # SQL server hostname
    db-user = ispconfig             # SQL server username
    db-password = 532836e53697343a2b52fc5f783de4c7         # SQL server password
    database = dbispconfig          # MyDNS database name
    
    
                                    # GENERAL OPTIONS
    
    user = nobody                   # Run with the permissions of this user
    group = nogroup                 # Run with the permissions of this group
    listen = *                      # Listen on these addresses ('*' for all)
    no-listen =                     # Do not listen on these addresses
    
    
                                    # CACHE OPTIONS
    
    zone-cache-size = 2048  # Maximum number of elements stored in the zone cache
    zone-cache-expire = 60  # Number of seconds after which cached zones expires
    reply-cache-size = 2048 # Maximum number of elements stored in the reply cache
    reply-cache-expire = 30 # Number of seconds after which cached replies expire
    
    
                                    # ESOTERICA
    
    log = LOG_DAEMON        # Facility to use for program output (LOG_*/stdout/stderr)
    pidfile = /var/run/mydns.pid    # Path to PID file
    timeout = 120   # Number of seconds after which queries time out
    multicpu = 1    # Number of CPUs installed on your system
    recursive =                     # Location of recursive resolver
    allow-axfr = yes # Should AXFR be enabled?
    allow-tcp = yes  # Should TCP be enabled?
    allow-update = no       # Should DNS UPDATE be enabled?
    ignore-minimum = no     # Ignore minimum TTL for zone?
    soa-table = dns_soa     # Name of table containing SOA records
    rr-table = dns_rr       # Name of table containing RR data
    soa-where = server_id = 1               # Extra WHERE clause for SOA queries
    rr-where =  server_id = 1               # Extra WHERE clause for RR queries
    use-soa-active = yes # To fix bug 295 where active or inactive status is ignored.
    use-rr-active = yes# To fix bug 295 where active or inactive status is ignored.
    ~
    ~
    ~
    ~
    "/etc/mydns.conf" [noeol] 55L, 2380C
    I searched on howtoforce forum and google, but I couldn't find my problem. Do you know or resolve a problem, please help me.
     
    Last edited: May 25, 2009
  2. akamarinos

    akamarinos New Member

    in /etc/mydns.conf

    fill in the
    Code:
    recursive =                     # Location of recursive resolver
    with your isp dns
     

Share This Page