Have a domain that is being sent to the wrong website

Discussion in 'ISPConfig 3 Priority Support' started by webguyz, Feb 9, 2021.

  1. webguyz

    webguyz Active Member HowtoForge Supporter

    Running 3.13 and have a server that has 2 different websites. When you type in https://domain-a.com , it takes you to https://domain-b.com.
    No redirects and I tried to deactivate and reactivate domain-a.com. Checked the .vhosts and they look normal and have different Client and Web numbers. name based both have * for IP address
    What could be causing this?

    Thanks
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Does the vhost file for domain-a have an ssl virtualhost definition, pointing to correct certificate files?
     
  3. webguyz

    webguyz Active Member HowtoForge Supporter

    Both sites have LetsEncrypt SSL and during troubleshooting I did remove and re-install LetsEncrypt on domain-a.com.
    Just for grins I went to a remote server and tried accessing domain-a.com and it worked!
    I believe my local browser had cached the info when I initially tried it this morning and kept it even after I stopped/restarted SSL.
    Went to a third remote site and tried it there and it worked as well. Have not cleared my local browser yet but will do that next.
    Thanks.
     
    ahrasis likes this.

Share This Page