Harden PHP5 With Suhosin On CentOS 5.4

Discussion in 'Server Operation' started by fastsvc, Mar 11, 2010.

  1. fastsvc

    fastsvc New Member

    i am using the tutorial How To Harden PHP5 With Suhosin On CentOS 5.4

    and i am getting this error when i get to the step to rebuild php, this it the error i am getting after i type : rpmbuild -ba php.spec
    # rpmbuild -ba php.spec
    cat: /usr/include/httpd/.mmn: No such file or directory
    error: Failed build dependencies:
    httpd-devel >= 2.0.46-1 is needed by php-5.1.6-24.5.i386
    i ran :
    yum install httpd-devel

    then i got this message:
    # yum install httpd-devel
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * addons: mirror.sanctuaryhost.com
    * base: yum.singlehop.com
    * extras: mirrors.liquidweb.com
    * updates: mirrors.tummy.com
    Excluding Packages in global exclude list
    Finished
    Setting up Install Process
    No package httpd-devel available.
    Nothing to do




    any help please?
     
    Last edited: Mar 11, 2010
  2. falko

    falko Super Moderator ISPConfig Developer

    That's strange. Anyway, you can download the package manually...
    Code:
    wget http://ftp-stud.fht-esslingen.de/pub/Mirrors/centos/5.4/updates/i386/RPMS/httpd-devel-2.2.3-31.el5.centos.2.i386.rpm
    ... and install it as follows:
    Code:
    yum install httpd-devel-2.2.3-31.el5.centos.2.i386.rpm
     
  3. fastsvc

    fastsvc New Member

    Check php for Suhosin

    I tried the instructions in a new server and they work fine i guess the steps don`t work after you install directadmin for some reason.
    i tried to install the Suhosin extension but i got a message saying php-devel is missing so i tried :
    yum install php-devel

    and instead of installing php-devel i got this message:
    No package php-devel available.

    Maybe that should be the next tutorial (how to install Suhosin in a server running directadmin ).
     

Share This Page