Harddisk usage wrong

Discussion in 'General' started by Erik Damber, Jun 5, 2020.

  1. Erik Damber

    Erik Damber Member

    Hello
    I have a couple of sites out of my 130 that shows the wrong usage. Both on different servers. First one shows 15GB used when it actually uses 37GB. Other one shows 49GB used but it uses only 0.5GB. There is a third one also that is wrong but that one I recently migrated to another ISPconfig setup but yesterday I transferred it back to this one, shows 500MB usage but it's 49GB.

    I tried resync tool. Seems like most of the other sites all have the right usage. Any ideas on how to troubleshoot this?

    /E
     
  2. Th0m

    Th0m ISPConfig Developer ISPConfig Developer

  3. Erik Damber

    Erik Damber Member

    Tried the script doesn't work. Doesn't seem to be any tmp files or something like that laying around either on that user:group. First one might be because Ive changed the VM to thin provisioning and added zeroes and performed hole punching, not sure. But the second one which shows lower than actual usage I haven't done anything in years too. Updated ISPconfig recently on panel if that matters.

    Any good find/grep command to look for web6:client7 on all places except /var/www/clients/client7? That folder is only 500MB.
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer ISPConfig Developer

    Code:
    find / -user web6 | grep -v /var/www/clients/client7
     
  5. Erik Damber

    Erik Damber Member

    I can still upload files to that client though, even when we have a 20GB harddisk quota. They are over 37GB. So that part doesn't seem to work either. Before saving files didn't work when you passed the quota.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you have a problem with your base system setup, seems as if harddisk quota is not working or not configured for the partition that contains the website files.
     
  7. Erik Damber

    Erik Damber Member

    Wierd only 2 sites out of 130 split on 25 servers have the wrong values. Here is the fstab for the one that shows 49 GB instead of 0.5GB
    /var/log/ispconfig/httpd/obs.kulturhotell.se /var/www/clients/client7/web6/log none bind,nobootwait 0 0
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The line you posted is the BIND mount of the log file, that's not quota related. What you can try is to turn quota off, let Linux recalculate quota and turn it on again.
     
  9. Erik Damber

    Erik Damber Member

    Comment these in fstab and reboot? errors=remount-ro,usrquota,grpquota 0 1
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Try these commands:

    quotaoff -avug
    quotacheck -avugm
    quotaon -avug
     
  11. Erik Damber

    Erik Damber Member

    That didn't help the first one which displays 50Gb usage when it's only 0.5GB.
    Did that on the other server which had one that showed 15GB instead of 37GB and it worked there.

    First one is wierd though. It's the only user with a grace period too, 6days.
     

Share This Page