Hack to Fix SMTP problems after upgrading from Sarge to Etch

Discussion in 'Server Operation' started by Ardesco, Oct 20, 2007.

  1. Ardesco

    Ardesco New Member

    I am running postfix with virtual domains on my mail server and upgraded from Sarge to Etch this week.

    All went well apart from the fact that I could not send anything through SMTP (worked when sending locally through webmail). After digging about in the logs for an age it became apparent that saslauthd was not picking up the -r switch in the options line in the config file and sending the username without the domain appended

    (Why I have no idea, double checked the config file location and everything else, uninstalled postfix and rebuilt with the same result, made some sym links from other locations where the file could default, etc)

    So I performed a small hack to the saslauthd init file in /etc/init.d/saslauthd

    vi /etc/init.d/saslauthd
    Modify the following line and add in -r:
    # Add our mechanimsms with the necessary flag
    PARAMS="${PARAMS} [B]-r[/B] -a ${MECHANISMS}"
    This has got everything up and running again and may be some use to the people on these forums having similar problems and have not been able to fix it yet (thought I would post it here as searching the net for hints/answers pointed me to this forum on many occasions).

    Hope it helps

Share This Page