Gsuite Gmail problem

Discussion in 'General' started by Donno, Oct 30, 2018.

Tags:
  1. Donno

    Donno Member

    After moving a client to ispconfig3 server and config MX records and SPF for Gsuite gmail

    MX example.com. aspmx.l.google.com. 10 3600
    TXT example.com. v=spf1 include:_spf.google.com ~all 0 3600
    CNAME
    mail ghs.google.com.

    after 12 hours client still not receiving mail

    After using gsuite toolbox to check mx records gives me the following
    warning DKIM is not set up.
    warning DMARC is not set up.
    warning There should not be a mail exchanger set up on naked domain name.

    I check mail logs and mail gets send to aspmx.l.google.com. I can't seem to figure out why this is, anyone else had problem like this before ? Also tried leaving hostname blank but still no results.

    NOTE I used afraid.org previously and my setup as follow
    example.com (G) MX 10:aspmx.l.google.com
    mail.example.com (G) URL https://www.google.com/a/example.com/
     
  2. Donno

    Donno Member

    If someone can maybe share there setting that would also be great :)
     
  3. ahrasis

    ahrasis Well-Known Member

    There should be 5 MX records but I can see you only have one? Please check with GSuite guides. I will share mind later if this is still not resolved.
    I am not sure if GSuite will have a fix on that.
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    If your MX record in ISPConfig is
    Code:
    MX example.com. aspmx.l.google.com. 10 3600
    then e-mails should go to aspmx.l.google.com.
    But seems this is not what you want, since you write
    Use command
    Code:
    host example.com
    it shows you "mail is handled by ...", so you can see where the emails sent to @example.com addressess are going.
     
  5. Donno

    Donno Member

    I waited really long and nothing happened in google under Google Admin -> Apps -> Gsuite -> Gmail -> Advance Settings it showed old ip address i decided to make a new email address, after that all worked. Think it was Google problem. I will update the records again this weekend to those 5 records and play around with settings as i don't want to disturb clients too much during the week. Will give an update then.
     
    ahrasis likes this.
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  7. Donno

    Donno Member

    I have setup DNS record as follow

    Yes MX example.com. aspmx.l.google.com. 10 60
    Yes
    MX example.com. alt1.aspmx.l.google.com. 20 60
    Yes MX example.com. alt2.aspmx.l.google.com. 30 60
    Yes MX example.com. alt3.aspmx.l.google.com. 40 60
    Yes MX example.com. alt4.aspmx.l.google.com. 50 60

    and waited a few days and tested the email

    Sending and receiving works fine but sending from local server to gsuite does not work but sending from gsuite to local server works

    Example :
    I have 2 clients domain on ispconfig server example.com and example0.com. example.com uses aspmx.l.google.com MX record and example0.com uses local mx record hosting.com[ISP server]. Sending mail from yahoo.com[outside] to example.com[gsuite] works and visa versa. Sending mail from example0.com[local] to example.com[gsuite] does not work. but sending from example.com[gsuite] to example0.com[locally] does work. example0.com can send out emails and receive fine, just can't send to gsuite that has local DNS records pointing to Yes MX example.com. aspmx.l.google.com. 10 60
     
    ahrasis likes this.
  8. nhybgtvfr

    nhybgtvfr Active Member

    do you have example.com configured as a mail domain in ispconfig? if so, your local mail server (assuming it's a member of the ispconfig system) will believe it's responsible for that mail domain. that means any email being sent via that server to an example.com address will be treated as a local mailbox delivery, it will not be performing any mx record lookups.
     
    ahrasis and Taleman like this.
  9. ahrasis

    ahrasis Well-Known Member

    I also hope you also enabled 2-Step Verification and use its token instead of account password. Last time I managed mine, it won't work properly without this.
     
  10. Donno

    Donno Member

    I did not add example.com to email domain in ISPConfig

    In gmail ? i use password to log into G suite. Please explain more !
     
  11. ahrasis

    ahrasis Well-Known Member

  12. Donno

    Donno Member

    Google saw my emails as poor reputation fixed it by setting up DKIM and DMARC Records. You can also check domain using mxtoolbox this tool helped a lot. :)
     
    ahrasis likes this.

Share This Page