grub quota issue on centos 7

Discussion in 'Installation/Configuration' started by sygram, Mar 12, 2016.

  1. sygram

    sygram Member

    Hi guys,

    i followed this guide https://www.howtoforge.com/perfect-...l-php-pureftpd-postfix-dovecot-and-ispconfig3 to setup ispconfig to my server. The only issue that i had was regarding quota on a software raid.

    I tried to add rootflags=uquota,gquota to GRUB_CMDLINE_LINUX, rebuilt grub.cfg but the server would not boot. Then i checked one post below and saw instead of gquota to use pquota. Did that, same issue.

    This is what i have in /etc/default/grub

    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
    GRUB_DEFAULT=saved
    GRUB_DISABLE_SUBMENU=true
    GRUB_TERMINAL_OUTPUT="console"
    GRUB_CMDLINE_LINUX="nomodeset rd.auto=1 crashkernel=auto"
    GRUB_DISABLE_RECOVERY="true"

    Then i edited fstab and added the below usrquota,grpquota to / resulting in :

    proc /proc proc defaults 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    sysfs /sys sysfs defaults 0 0
    /dev/md0 none swap sw 0 0
    /dev/md1 /boot ext3 defaults 0 0
    /dev/md2 / ext4 defaults,usrquota,grpquota 0 0

    I rebooted the server without rootflags=uquota,gquota and it boots fine.

    Command : mount | grep ' / ' reports :
    /dev/md2 on / type ext4 (rw,relatime,quota,usrquota,grpquota,data=ordered)

    so i guess quota is enabled on /

    My concern is whether grub value is important. Is ISPConfig going to be affected by this ?

    Thank you very much.

    Regards
     
  2. ztk.me

    ztk.me Active Member

    How about
    Code:
    rootflags=usrquota,grpquota 
    It is only needed if you want/need to enforce quotas. If you don't set them up, ISPConfig will function anyway - just without quota limitations functioning.
     
  3. sygram

    sygram Member

    Thanks for replying.

    I would like to use quota from ISPConfig. Am i ok with the fstab that i have now ?

    I also noticed that you posted "rootflags=usrquota,grpquota" . I haven't check this setting. Only rootflags=uquota,gquota and rootflags=uquota,pquota that didn't work.

    How can i check if ISPConfig will apply quota ?
     
  4. ztk.me

    ztk.me Active Member

    Yes I've seen your entry and no, setting up quotas has to be done by using boot params in Centos7 ( if it's the root partition ).
    You can check your current set disk quotas ( may not apply to dovecot since it handles quotas itself ):
    Code:
    repquota -avug
    
    
    I got my assumption about my suggested rootflags setting from here ( eBook Mastering Centos 7 ) - so I think it's worth trying it.

    Edit: I possibly was wrong, overlooked you're using ext4 filesystem. Your /etc/fstab entry should be fine. I'm sorry for that, absolutely my fault.


    See why:
    http://www.unix.com/man-page/centos/8/quotaon
     
    Last edited: Mar 12, 2016
  5. sygram

    sygram Member

    Hi there,

    thanks for your reply. Much appreciated.

    Regards
     
    ztk.me likes this.

Share This Page