grpconv running 99.7% processor 93% memory

Discussion in 'General' started by dsadm, Mar 10, 2007.

  1. dsadm

    dsadm New Member

    After reading the forums and other people's issues I still can't understand how to control the grpconv from taking over our production web server. I have noticed it takes over the system when I log into ISPconfig and do not have to do anything except keep it open. After running ISPconfig it takes a long while for grpconv to stop running and some times it does not. This is very problem matic since I am not running this on the top server hardware with gigbytes of memory.

    How can I control grpconv so it will not use up all the systems resources all the whole while and making it harder for people to use the webserver?

  2. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use? And which ISPConfig version?
  3. dsadm

    dsadm New Member

    This server is using Ubuntu Edgy on a 500 mhz PPC. ISPconfig version is 2.2.8. When I upgraded to this version I had the worst problems and had to start from scratch including the orrig DB. It is only when using ISPconfig control panel I get the full system resources used by the grpconv.

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Grpconv is not a ISPConfig command, it is a general linux command.

    From the manpage:

    If this commands causes problem on your setup, your linux installation has a general problem that is not nescessarily related to ISPConfig. If I run grpconv on several linux systems with ISPConfig, it returns instantly and does not caiuse any load.

    You should check your passwd and group files with the commands:

  5. dsadm

    dsadm New Member

    I first thought it was a general linux issue but the only time grpconv ran and gave issues was when I used ISPconfig, other than that, I was not able to duplicate the same issue another way.

    However using the commands you sujested did seam to help. Now when using ISPconfig I do not see the grpconv command eating all the processor speed as it had done before. While using ISPconfig I continue to watch the processes to make sure and every thing is working perfectly.

    Thank you for the extra help.

  6. ru916b

    ru916b New Member

    I hit same problem on Fedora Core x86_64

    I hit the same problem:

    -- Fedora Core 5 on X86_64;
    -- 2 Dual-core Xeon Processor;
    -- ISPConfig 2.2.11;

    I have 2G physical memory, and set up 32G swap as my system supports max of 32G memory which I plan to add in.

    I noticed that when I update the site info or sth else, the 'grpconv' was taking over 100% CPU and keeps exhausting the memory, it even uses 32G swap memory in one day.

    I couldn't reproduce this out side of ispconfig. I am still wondering in which cases, ispconfig fires up this 'grpconv' command so that i may have a better clue.

  7. ru916b

    ru916b New Member

    After running 'grpck', it showed there were duplicated entry for 'web2' which was created by ispconfig. After deleting the duplicated entry, 'grpconv' returns instantly.

    So it looks 'ispconfig' sometimes does not check the '/etc/group' entry completely before adding one. I sometimes got error 'cannot lock /etc/group' reported by 'grpconv'.

    Thanks for the info and tips.

    -- James
  8. falko

    falko Super Moderator ISPConfig Developer

    Did you create some groups manually with a conflicting group ID (i.e., an ID in starting from 10000 - these are used by ISPConfig)?
  9. ru916b

    ru916b New Member

    conflict group

    No. I did not manually create those conflict groups. But I did install some other software without ispconfig which might create some other groups, e.g. bugzilla, subversion, mailman etc.

  10. till

    till Super Moderator Staff Member ISPConfig Developer

    This might have been the problem. If the installers of the software created groups in the groupid range of ISPConfig.
  11. RicochetPeter

    RicochetPeter New Member

    argh, today I ran into this problem:

    11528 ? S 0:04 /bin/bash /root/ispconfig/sv/ispconfig_wconf
    1221 ? S 0:00 \_ /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php
    1490 ? S 0:00 \_ sh -c grpconv &> /dev/null
    1491 ? R 12:42 \_ grpconv

    the last process, grpconv, was using up all available memory, finally causing a kernel oom-killer, which is just a tad bit before the ooops.

    Thing is that linux "groupadd" simply takes the highest group number it finds and adds 1 to it to create a new group, which is the easiest method to do it.

    Actually, I'd prefer ispconfig to do it the same way instead of using a "number space". What do you think?

    Edit: hmmm, bulls*** what I just wrote. You already have that dummy 20000 group there. So what the heck made that other programme use 10141 as group number?? ...
    Last edited: Feb 4, 2008

Share This Page