Groups totally gone.

Discussion in 'Installation/Configuration' started by untg, Dec 19, 2009.

  1. untg

    untg New Member

    I've installed a new server and it seems to be working ok, until I has a look at /etc/group and there is only one listing,
    client1:x:100:www-data
    Is that normal for ispconfig3, I would have thought /etc/group had more listings?

    I just installed apt-get install ubuntu-desktop so I don't know if that would have anything to do with it.

    Is someone able to sent me their newly installed ISPConfig3's group file? I'm sure mine has something seriously wrong with (I only installed the server two days ago).

    Thanks
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Do you have a backup of /etc/group? What's the output of
    Code:
    ls -l /etc/group*
    ?
     
  3. untg

    untg New Member

    I've reinstalled since then but i'll remember to backup the groups file and passwd file.
    Just wondering if there is any reason why that would happen or just a freak accident of some package.
     
  4. untg

    untg New Member

    Just in case anyone else has this problem, I just noticed that it looks like backups are kept in /var/backups/ automatically by debian/ubuntu.

    So I could have probably just restored /etc/group from /var/backups.

    oh well, next time :)
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    ISPConfig 3 does not manage the /etc/group file directly, it uses only the groupadd command from ubuntu to add groups, so its very unlikely that this has been caused by ispconfig.
     

Share This Page