Great or not!

Discussion in 'Installation/Configuration' started by shoevring, Mar 11, 2010.

  1. shoevring

    shoevring New Member

    Hello every one..

    I just updated my mainweb server with 3.0.2,

    Before i start, you should get some info about my installation.

    I have 3 servers.

    Server 1: mainweb > To controlpanel
    Server 2: web1 > Webserver1 without controlpanel
    Server 3: web2 > Webserver2 without controlpanel

    I just updated mainweb, but now i can't login with my logins and no off my clients can..

    Where is nothing in sys_user(mysql-table) but my clients is still there, but can't login.

    All webpages, mails works fine on web1 and web2..

    In installation i just followed the installation guide..

    I'm very in stock here.. Any some can help me to fix this problem?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If you use a multiserver system, yoiu have to update the slave servers first and then update the amster server.

    Also it looks like you have modified the sys_user table. Did you change a colum or added a column in this database table or any other table on the mainweb server?
  3. shoevring

    shoevring New Member

    Yes i have a multiserver system, but why did the server delete everything? Domains, subdomains, mails, everything besides client information in client table..?

    No, i did't - it was a clean ispconfig.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The server did not delete everything, the update was just not able to load the database content into the table structure. The problem is that the structure of your database content does not match the ispconfig database structure. Did you install any third party plugins like the akTicket extension for ispconfig?

    You can find a backup of the database content in the root folder as .sql file. Please load this database content back into the empty database with phpmyadmin. If phpmyadmin shows an error, please post it.
  5. shoevring

    shoevring New Member

    No, and nice! but there is an error:

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok. Maybe its a database corruption in this case as mysql seemed to have created two dupliacte records in a auto increment column which should not be possible. You can try to remove all indexes from the client table and then try to import the dump again.
  7. shoevring

    shoevring New Member

    Great man! after i delete dumps in client, an error from client_template, countrys and more comes..

    I think i want to start over..

    Are the 3.0.2 the same install requirements like 3.1.6 ?
  8. shoevring

    shoevring New Member

    And.. How do i backup my clients mail? When i want to move it to the new server?
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Make a backup of the broken database.
    2) Truncate (empty) all database tables in this database but dont delete them.
    3) Try to load the database dump that was made as ispconfig was updated into the database.


    But the software install is not broken, its just a problem with the database that should be fixable. So I do not recommend to start over.

    make a tar.gz of the cmail directory. e.g.

    tar pcfz email_backup.tar.gz /var/vmail
  10. shoevring

    shoevring New Member

    I think its better, i just installed the new serveres(all 3)

    And i just try to overwrite mailboxes(I have already created them in ispconfig)

    I took backup from my old mailserver(/var/vmail) and put it in the new mail server, but the squirrelmail can see the folders i have previously created, but cant open them, i try to run this command on the ssh: chown -r www-data:www-data /var/vmail but i think it not right.. So i tried again with postfix user, and now it cant connect("ERROR: Connection dropped by IMAP server.")

    How can i get this to work corretly?

    And thanks for your great help!
  11. shoevring

    shoevring New Member

    I got it to work.. Command: chown -R vmail:vmail /var/vmail, ;)

    Thanks a lot for a good support :)

Share This Page