got eveything I need for an blocked 25 port and now?

Discussion in 'Installation/Configuration' started by Appie Thrasher, Jan 5, 2007.

  1. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    Okee, my isp is blocking port 25. So I now have got myself an acount at DynDNS
    the mailhop service.

    I have got from DynDNS an server like this:

    Host= mydomain.nl preference= 10 data= mx1.mailhop.org.

    Can any body tell me where to put it? I now it must work because yesterday I made some chanches and when I was looking in the maildir with webmin I actulaly got mail (the test mails I send myself).

    Today its not working any more but that is because I dont know what I have done yesterday:eek: . I have tried everything I couldt think of wath I did yesterday but now go.

    I think I must put it in the dns manager by records? There I made yesterday the most chanches. Can somebody point me the right way again.

    TIA DaRKNeSS
     
  2. falko

    falko Super Moderator ISPConfig Developer

    If your ISP is blocking port 25, then you can send mails internally on the server (e.g. webmin can send mails to you), but nobody can send mails to you from the outside.
     
  3. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    Ehhhh,

    Corect me if I am wrong but the dns service i have subscriped to is espescialy for persons like myself with an blocked port 25.

    This service is catching the mail send to my and redirect to an diferend port.
    In my case port 2525.

    From the Dyndns site

    I have made some changes to the master postfix file {master.cf]

    smtp inet n - - - - smtpd
    2525 inet n - n - - smtpd I have added this line to listen to port 2525 Ihope
     
    Last edited: Jan 6, 2007
  4. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Did you restart postfix? What the output of
    Code:
    netstat -tap
    ?
     
  5. Hans

    Hans Moderator ISPConfig Developer

    A friend of my has the same problem as you do.
    What he did was configure your MTA to send email via port 2525 in stead of 25.
    He send his email via port 2525 via http://www.rollernet.us/ and they send the mail via port 25 to your final destination.

    The MX10 record should be: 10 mail.rollernet.us.
    The MX20 record should be: 20 mail2.rollernet.us.

    I do not prefer this kind of solutions, but if you really want to send email via your own MTA, you can do it like that.
    In Holland are also a few Internet Service Providers who do not block port 25 like XS4ALL and Quicknet.
    You can considder to make a step to one of those ISPs and you will be able to send email via port 25.

    For more info check URL http://www.rollernet.us/
     
  6. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    I think I have finaly got it to work. I am receaving mail, asked some people to send me an email, so I am still testing and still receving. I changed the mailserver setting from internal to external. I hope it will keep on receving mails.

    @martinfst
    Yes I have restarted postfix. But thanks for thinking with me

    @Hans
    I indeed would prefer for instance xs4all. But I don't have an tel line any more and if I must get, and an new tel line, and the fast xs4all it's a lot more expensive than I have now.

    I am still finding out hat to do with webhosting. For me it's just an big hobby. Mabey in the future if I know wath the ... I am doing I wil get my own server in an datacenter or get an reseller isp.

    DaRKNeSS
     

Share This Page