Gonna Loose My Mind About Permissions

Discussion in 'Installation/Configuration' started by tolgata, Jan 9, 2007.

  1. tolgata

    tolgata New Member

    I was using suse for several years but i never used a control panel and i decided to use ispconfig
    I downloaded and installed it into my server(which is suse 10.2) and i added my domains to ispconfig howevery when i upload php files their default permissions are without execute(however folder's settings include execute) and when i try to run the index.php by giving it execute permission for everyone it doesnt execute ,it just try to download the index.php file like php support didnt enabled(but it did).
    I'm gonna loose my mind why this is happening and I need a quick answer pls because my clients are extremly mad about this situation
     
  2. tolgata

    tolgata New Member

    if this has no solution how can i uninstall it and turn everything back to normal
     
  3. dragonslayer

    dragonslayer New Member

    do you have apache & php running, in YaST -> Network Services -> Network Services (xinetd) -> Toggle Status on...make sure everything is on,

    as far as permission "chmod 777" which is rwx
     
  4. Neg127

    Neg127 New Member

    What is the default umask in your ftp config file?

    If you would like all directorys set to 755 and all files set to 644. You can make new files in the directory and also have the php or cgi files read and executed by default. You would need to set your umask to 022.
     
  5. tolgata

    tolgata New Member

    I have changed the vsftpd.conf's local_umask variable to 022 however nothing changed the files I uploaded still seems as unexecutable to users.
    And I also wonder how this will help me to execute php files instead of downloading them because when i give it execution permission by hand with chmod 755 ispconfig doesnt make it executable by client side it makes client to download php file like php doesnt work but it is
     
  6. martinfst

    martinfst HowtoForge Supporter

    All FTP servers put your files with maximum rw-rw-rw permissions. It would be a real security concern if FTP'ed files were directly executable. Do it manually, so you know what you enable on a server.
    If the chmod'ed 755 .php files are not executed in your webserver (I assume that's what you want), then your webserver configuration is not correct. Are you able to execute a simple php script in your web? Is a simple html file served properly?
     
  7. isural

    isural New Member

    Apache problem

    I think your problem is apache config problem. If .php files downloaded from web server this means there is misconfiguration somewhere.
    in httpd.conf you should check the configuration parameters carefully.
     

Share This Page