Global Search issue

Discussion in 'Installation/Configuration' started by osterhase, May 30, 2013.

  1. osterhase

    osterhase New Member

    Hi there!

    We just updated our ISPConfig Installation to - everything ran smooth. Especially the global search feature seemed very convincing. But we ran into an little issue here - maybe someone can give us a hand here:

    Our ISPConfig installation does not have a separate domain but ist served from http://[ourcompany]/ispconfig - the issue is, that the ajax request for the global search is send to http://[ourcompany]/dashboard - and our WCMS tries to answer... obviously 404.

    How should we configure your Apache to handle the ajax request correctly? Below is the config we are using... any help is appreciated.

    # ISPConfig
    Alias /ispconfig /var/www/ispconfig
     <IfModule mod_fcgid.c>
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
      <IfModule mod_php5.c>
        AddType application/x-httpd-php .php
        <Directory /usr/local/ispconfig/interface/web>
          Options FollowSymLinks
          AllowOverride None
          Order allow,deny
          Allow from all
    	  php_value magic_quotes_gpc        0
  2. cbj4074

    cbj4074 Member

    Implement some kind of Apache (or nginx) mod_rewrite rule.

    An important question to ask yourself: What other interfaces will fail for the same reason? Whichever solution you implement should take the answer into consideration.

    ETA: I would expect that the path in question is configurable in ISPC, in which case a mod_rewrite rule would be unnecessary. Can any of the developers comment?

Share This Page