git version 3.1dev | pure-ftpd-mysql doesn't start

Discussion in 'General' started by dynamind, Jun 11, 2015.

  1. dynamind

    dynamind Member

    I upgraded to the git version which looks very promising. However I suggest to disable mongo-db monitoring by default if not even installed.
    Now pure-ftpd-mysql doesn't start and appears to be offline. Can I provide logs to fix the issue?
    I downgraded as there appeared several other small issues.
    Now I get a problem with mailing:

    Jun 11 16:59:33 ispc amavis[21768]: Creating db in /var/lib/amavis/db/; BerkeleyDB 0.51, libdb 5.1
    Jun 11 16:59:37 ispc postfix/proxymap[21772]: warning: request for unapproved table: "mysql:/etc/postfix/"
    Jun 11 16:59:37 ispc postfix/proxymap[21772]: warning: to approve this table for read-only access, list proxy:mysql:/etc/postfix/ in
    Jun 11 16:59:37 ispc postfix/smtpd[21771]: fatal: proxymap service is not configured for table "mysql:/etc/postfix/"
    Jun 11 16:59:38 ispc postfix/master[21410]: warning: process /usr/lib/postfix/smtpd pid 21771 exit status 1
    Jun 11 16:59:38 ispc postfix/master[21410]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    fixed it restoring courier and postfix folder from etc.tar.gz backup!

    One more : ) hehe

    imapd.pem: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
    best regards
    Last edited: Jun 11, 2015
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    You can not downgrad from 3.1 to 3.0.5.x.
    And why don´t pureftp starts? On my dev-server i can use pureftpd?
  3. dynamind

    dynamind Member

    I already succesfully downgraded, but first of all I had to restore some etc folder from backups.
    It was necessary to go back to stable, cause PHP IDS is warning about a loop injection at inserting certificates and the mailsystem was throwing a missing proxy error after the downgrade. Also I noticed a warning after upgrading regarding mysql:
    TCP: request_sock_TCP: Possible SYN flooding on port 3306. Sending cookies.  Check SNMP counters.
    I increased tcp_max_syn_backlog but it did not fix the issue.
    If I can contribute logs please tell me which ones.
    Folders I needed to restore for a successful downgrade from etc.tar.gz was:


    Regarding the certificate error: created new certs and now everything is fine again ;)

    So do you already provide a 3.1 manual, if I'm willing to donate once more?

    thanks for your reply

    best regards
    Last edited: Jun 12, 2015
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The 3.1 manual is not finished yet. It will be available when 3.1 gets released.
  5. dynamind

    dynamind Member

    Hi Till
    Pre-Order possible? I think you absolutely deserve a contribution ...
    I see your project is heading into the right direction.
    So many useful, smart and awesome improvements in sight!
    Also it's possible I could need help with my class2 wildcart cert.

    best regards
    Last edited: Jun 12, 2015

Share This Page