Ghost 4 Linux

Discussion in 'Installation/Configuration' started by willebanks, Oct 6, 2006.

  1. willebanks

    willebanks New Member

    Howdy all,

    Now that my server is up and running I have concerns about hard drive failure or if I make a change and it screws something up system wide! Raid 5 is out as the expense is not justifiable at this time and Raid 1 only helps in the event of a hard drive failure.

    Many of the backup options seem to be extremely compilcated or only backup a small section or files. I have had lots of experience with Norton Ghost but it appears as if that is only for Window machines...Yet in my search for a similar Linux program I found Ghost 4 Linux.

    I wonder if anyone here as had any experience with this software as I just can't seem to make it work...I keep getting IRQ errors and I'm told to use "irqpolling" whatever that is!

    I have always received excellent solutions to my Linux and server problems, which is why I'm asking here first. I do plan on trying to contact the programmers in the hopes of a solution with them.

    Thanks in advance as always,

  2. Hans

    Hans Moderator ISPConfig Developer

  3. FMccloud

    FMccloud New Member

    Help to restore backup of hard disk with "ghost for linux"

    I'm new in linux, I hope that somebody can help me with the problem that I have.

    I've made a backup of the hard disk (80GB SATA) of my server (fedora Core 6, Intel XEON at 3GHz), following as reference the article: “Back Up/Restore Hard Drives And Partitions With Ghost4Linux”. I used a FTP server for windows xp called: “Quick'n Easy Ftp server”. The result of the backup of the hard disk was successful (in fact the backup I twice did it in different equipment with the same number of bytes) , the detail is at the time of recovering the backup, because when initiating the restoration, g4l shows me the following:

           0.00% Starting
           ncftpstatus OK
    [                                0%                                      ]
    Lzop: <stdin>: not a Lzop file 0%
    And I'm sure that my file was made it with compression type Lzop. After that, g4l shows me:

           OK Remote host has closed the connection

    The log file of the FTP server shows the following:
    08:38:42.187 [508] Client connected from
    08:38:42.187 [508] 220 Welcome to Quick 'n Easy FTP Server
    08:38:42.187 [508] USER anonymous
    08:38:42.187 [508] 331 Password required for anonymous
    08:38:42.187 [508] PASS NcFTP@
    08:38:42.187 [508] 230 User successfully logged in.
    08:38:42.187 [508] PWD
    08:38:42.187 [508] 257 "/" is current directory.
    08:38:42.187 [508] FEAT
    08:38:42.187 [508] 502 Command not implemented - Try HELP.
    08:38:42.187 [508] CLNT NcFTPGet 3.2.0 linux-x86-glibc2.3
    08:38:42.187 [508] 502 Command not implemented - Try HELP.
    08:38:42.187 [508] TYPE I
    08:38:42.187 [508] 200 Type set to I
    08:38:42.187 [508] PASV
    08:38:42.187 [508] 227 Entering Passive Mode (159,16,223,149,4,0).
    08:38:42.187 [508] RETR img/image.img.gz
    08:38:42.203 [508] 150 Opening BINARY mode data connection for file transfer.
    08:38:42.296 [508] An exception occurred while processing command: RETR img/image.img.gz
    08:38:42.312 [508] Could not send reply, disconnected.
    08:38:42.312 [508] Client disconnected from
    By the way, I try to recover the backup to partition SDA1 of 90GB of a hard disk of 320GB (SDA).

    What I do not know is if I must give format previously to the partition (and if it is, thus, in which file format?) or if the restoration of the backup must become to a hard disc of same size.

  4. falko

    falko Super Moderator ISPConfig Developer

    Your FTP server doesn't seem to support all FTP commands. Try another one.
  5. FMccloud

    FMccloud New Member

    Thanks, now I have another problem

    Thanks for your answer Falko.

    I used FILEZILLA Server, and that worked well. I recovered the backup that I did. Now the problem is that when initiating with the new hard disk, the screen shows:

    GRUB _
    And I can't do nothing, because it does not respond the keyboard. have I to format the hard disk before recovering the backup and if, thus in which format?

    Thanks! :)
  6. falko

    falko Super Moderator ISPConfig Developer

    Hm... You could try to boot from a Live CD such as Knoppix, then mount the hard disk, chroot to it, and try to repair GRUB with the commands update-grub or grub-install.
  7. FMccloud

    FMccloud New Member

    G4L works!

    Hi everybody:

    Again, thanks for your answer Falko. I tried to look for another solution before applying your advice, since I don't know much about linux.

    What I did was to format the hard disk, in format ext3 as primary type and I recovered the backup that I already had done and that worked.

    Falko, In truth I thank for much your aid.
    :) !

Share This Page