Getting "upstream timed out" timed out error with nginx and fastcgi

Discussion in 'HOWTO-Related Questions' started by pavs, Apr 24, 2013.

  1. pavs

    pavs New Member

    With the help of this 2 tutorial:

    I am running wordpress with nginx,apc,mysql,memcache,varnish,php-fpm.

    After months of running without any problem I have started to get this kind of error with "upstream timed out". Basically the site will work for hours without problem, but it go down with 1-2 times a day, I have to restart the server to get it back up again and the cycle goes on. It been happening only for the last month or so. Before that it worked without any problem for about six month. I had this problem with another server with exact configuration, I couldn't find any solution so I re-installed everything and its worked fine. I don't want to reinstall this if possible, because its a pain in the butt. serching the interwebs tells me that this is a common problem none of the solutions I tried works for me or anyone can explain why this happened. One of the more popuar solution offered is to switch to unix sockets, but it didn't solve my problem.

    Can anyone help?

    Example of an error from nginx error log:


Share This Page