getting shared IP page instead of website

Discussion in 'Installation/Configuration' started by andyreynolds, Feb 25, 2007.

  1. andyreynolds

    andyreynolds New Member

    i have now managed to fix my problem with my dns by changing the v hosts file thanks till for that. But now that the domain I want to host which is, a community sailing website like It comes up with this message

    'Shared IP


    This IP address is shared. For access to the web site which you look for, enter its address instead of its IP.

    For questions or problems please contact the server administrator.

    I can ftp the domain and get access to the user files and that works, is their something different I need to do in the configuration pages of the dns of the domain or something? As i should be getting the contents of what I uploaded and not this page which I get on the IP
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is your server behind a router in a NAT enviroment? If yes, you must choose your internal and not external IP for the website.
  3. andyreynolds

    andyreynolds New Member


    I have chosen the internal IP address for V Conf file, but not the bind service has stopped working. I am using this code in the monitoring section ‘/etc/init.d/named start’ on port 53. Should this turn the BIND service back on, why should it of stopped? When it was working last night I looked up the domain and it returned the SOA record but not the MX?? Yesterday it returned the shared IP message when you went on the domain but now it is just not working. As well as this if you go to it use to come up with the shared IP message, but now it is the apache test page. Can I start BIND remotely and is this all that is the problem being it offline?
  4. falko

    falko Super Moderator ISPConfig Developer

    To clear this up: for web sites you must use the IP address that you see in the
    output - this one can be local or public.
    For DNS, you should use the public IP address, or otherwise people from outside your LAN cannot access your domains.

    Any error messages in syslog regarding BIND?
  5. andyreynolds

    andyreynolds New Member

    showing shared ip message instead of website

    on the URL it displays a shared IP message, I can login to my ispconfig on port 81 but I normally I would expect to see a message saying 'this is your index.html' welcome message but I get the shared IP, why is this?
    I have got two other domains they are and, they both come up with shared IP message and I only get the homepage one on When I ftp to it the contents on the page doesn't change?
    Last edited: Mar 3, 2007
  6. Hawker

    Hawker New Member

    Since you didn't answer about being in a NAT behind a router, let's see if I can explain this a little better....

    If you are behind a router and using NAT you must route ports to the private IP address(es) you are using for your web sites. You must also create an ifcfg-ethX:X file for each private address you use. And then do a network restart.

    If you are not behind a router, or you are and are not using NAT you must create an ifcfg-ethX:X file for each public IP address you are using. And then do a network restart.

    With that said, either you haven't created the proper ifcfg files or you aren't NAT routing to them. At least that's my take on this.
  7. andyreynolds

    andyreynolds New Member


    I have got the correct ifconfig file for the extra internal IP address and I am successfully hosting one site which is showing the content that I am uploading. I have also set up my other two domains and, but they come up with shared IP page instead of the standard index.html page that when replaced with a new one changes the content of the website. This works for but not for the other two so it must be set up correctly otherwise the dns wouldn't work and it wouldn't load anything am I right?
  8. falko

    falko Super Moderator ISPConfig Developer

    What's in Vhosts_ispconfig.conf, and what's the output of
  9. andyreynolds

    andyreynolds New Member

    output code

    I get etho and etho:0 the first IP address is and the eth0:0 is The address is in my v hosts file and then that IP is DMZ to the IP and is DMZ to .131.
  10. falko

    falko Super Moderator ISPConfig Developer

  11. andyreynolds

    andyreynolds New Member

    method in my madness

    i transfered them back to my servers now as I thought that this would fix the problem as when I transfered I got the welcome to the index.html page, but on the other two I got shared IP page. I have now transfered them back now and want to see if I have fixed the problem. I have noticed know that the ftp transfer rate is slow for how is this?
  12. andyreynolds

    andyreynolds New Member


    I have uploaded joomla to my website and I find that they don't run. Even though I have php turned on, they just come up as downloadable files. How would I fix this? As I need to install joomla, and also an update on my other two sites (above) they have now come back to my server with the same error message 'shared ip message' when i ftp I find the standard index file in thir web directory and it isn't the shared IP message, it is welcome to index.html.
  13. falko

    falko Super Moderator ISPConfig Developer

    Please post your Vhosts_ispconfig.conf file.

Share This Page