getting problem with postfix and dovecot

Discussion in 'Server Operation' started by ayush1440, Jan 31, 2008.

  1. ayush1440

    ayush1440 New Member

    hello frends
    i m facing a problem with postfix and dovecot.i m using fedora core 6 and postfix-2.3.3-2 and dovecot-1.0-0.1.rc7.fc6..now my postconf -n detail is
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    command_directory = /usr/sbin
    config_directory = /etc/postfix
    daemon_directory = /usr/libexec/postfix
    debug_peer_level = 2
    html_directory = no
    inet_interfaces = $myhostname, localhost
    mail_owner = postfix
    mailq_path = /usr/bin/mailq.postfix
    manpage_directory = /usr/share/man
    mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
    mydomain = dharanetworks.com
    myhostname = server.dharanetworks.com
    mynetworks = 192.168.1.0/24, 127.0.0.0/8
    mynetworks_style = subnet
    myorigin = $myhostname
    newaliases_path = /usr/bin/newaliases.postfix
    queue_directory = /var/spool/postfix
    readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
    relay_domains = $mydomain
    relayhost = $mydomain
    sample_directory = /usr/share/doc/postfix-2.3.3/samples
    sendmail_path = /usr/sbin/sendmail.postfix
    setgid_group = postdrop
    unknown_local_recipient_reject_code = 550


    well now my network sceneraio is .. a isp directly connected to a route and route is a dhcp server. and we use router's ip as a default gateway we use on server and client..
    i configure postfix and dovecot and we use outlook express as a email client on client pc.. now when i m sending email from outlook .then error occures..i ll give u log detail. please tell me whats the problem?

    vi /var/log/maillog
    Jan 31 13:07:10 server postfix/smtpd[11152]: connect from unknown[192.168.1.6]
    Jan 31 13:07:10 server postfix/smtpd[11152]: 1DD731FA8632: client=unknown[192.168.1.6]
    Jan 31 13:07:10 server postfix/cleanup[11155]: 1DD731FA8632: message-id=<[email protected]>
    Jan 31 13:07:10 server postfix/qmgr[10967]: 1DD731FA8632: from=<[email protected]>, size=2180, nrcpt=1 (queue active)
    Jan 31 13:07:10 server postfix/smtp[11156]: connect to mail.dharanetworks.com[61.11.35.136]: Connection refused (port 25)
    Jan 31 13:07:10 server postfix/smtp[11156]: connect to dharanetworks.com[61.11.35.136]: Connection refused (port 25)
    Jan 31 13:07:10 server postfix/smtp[11156]: 1DD731FA8632: to=<[email protected]>, relay=none, delay=0.15, delays=0.03/0.01/0.12/0, dsn=4.4.1, status=deferred (connect to dharanetworks.com[61.11.35.136]: Connection refused)
    Jan 31 13:07:12 server postfix/smtpd[11152]: disconnect from unknown[192.168.1.6]
    Jan 31 13:07:16 server dovecot: pop3-login: Login: user=<admin>, method=PLAIN, rip=::ffff:192.168.1.6, lip=::ffff:192.168.1.1
    Jan 31 13:07:16 server dovecot: POP3(admin): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
     
  2. topdog

    topdog New Member HowtoForge Supporter

    Is the ip address 61.11.35.136 on that same server, looks like postfix is trying to verify the sender thus its trying to connect to the MX record and connections are not being allowed.
     
  3. ayush1440

    ayush1440 New Member

    ip is

    61.11.35.136 ip is our live ip who gave us by internet service provider ..
     
  4. topdog

    topdog New Member HowtoForge Supporter

    Is that on the router or on the mail server ?
     
  5. ayush1440

    ayush1440 New Member

    it is ADSL roueter ip which is given by our isp for broadband internet connection.
     
  6. topdog

    topdog New Member HowtoForge Supporter

    Can you maybe rename the server to mail.dharanetworks.com. or if not setup dns to have 2 views, mail.dharanetworks.com to point to local ip on the inside and mail.dharanetworks.com -> 61.11.35.136 on the outside.

    or try adding it to the /etc/hosts

    I am sure this is being caused by some kind of sender verification within postfix
     
  7. ayush1440

    ayush1440 New Member

    cannot understand log

    thank you ma frend..its working now..
    but when i m monitor log then sometime...
    Jan 31 11:26:40 server postfix/anvil[3162]: statistics: max connection rate 1/60s for (smtp:217.42.107.200) at Jan 31 11:23:17
    Jan 31 11:26:40 server postfix/anvil[3162]: statistics: max connection count 1 for (smtp:217.42.107.200) at Jan 31 11:23:17
    Jan 31 11:26:40 server postfix/anvil[3162]: statistics: max cache size 1 at Jan 31 11:23:17
    i see this log..
    so what is this? and if it is a virum,spam or something else..then tell me how can i prevent this..
    thaks again .. bro
     
  8. topdog

    topdog New Member HowtoForge Supporter

    Thats not a problem it is normal it is anvil with is a postfix program that keeps track of connections if you want to do some kind of connection limiting its what you use. So don't bother about it.
     
  9. ayush1440

    ayush1440 New Member

    thanx a lot ..
     
  10. ayush1440

    ayush1440 New Member

    plase help for this log

    warning: database /etc/aliases.db is older than source file /etc/aliases
    Feb 1 01:18:19 server postfix/smtpd[4825]: connect from 220-133-119-46.HINET-IP.hinet.net[220.133.119.46]
    Feb 1 01:18:21 server postfix/smtpd[4825]: NOQUEUE: reject: RCPT from 220-133-119-46.HINET-IP.hinet.net[220.133.119.46]: 554 5.7.1 <[email protected]>: Relay access denied; from=<[email protected]> to=<[email protected]> proto=SMTP helo=<61.11.35.136>
    Feb 1 01:18:21 server postfix/smtpd[4825]: lost connection after RCPT from 220-133-119-46.HINET-IP.hinet.net[220.133.119.46]
    Feb 1 01:18:21 server postfix/smtpd[4825]: disconnect from 220-133-119-46.HINET-IP.hinet.net[220.133.119.46]



    what is this log and what is the support@microsoft address? we never use that email address. so someone use? please help me
    thank you my frend
     
  11. topdog

    topdog New Member HowtoForge Supporter

    There is no problem there someone is trying to relay through your server, but its a good think that your server is configured well so it is rejecting the message.
     
  12. ayush1440

    ayush1440 New Member


    k .. really i worried to see this log..
    thank a lot..
    now i have 2 configure this mail through client MUA like outlook express. when i configure it i have 2 put my server's ip for pop3 and smtp connection but i want to put pop3.mydomain.com and smtp.mydomain.com. so what should i do for this?
     
  13. topdog

    topdog New Member HowtoForge Supporter

    You need to create DNS entires for those names pointing to that ip address.
     
  14. ayush1440

    ayush1440 New Member

    ok .i make entry like this
    pop3 IN A serverip
    smtp IN A serverip


    is that okey right i
     
  15. topdog

    topdog New Member HowtoForge Supporter

    Yes that will do it just increase the serial number of the zone as well
     
  16. ayush1440

    ayush1440 New Member

    apache-tomcat

    do you have knowledge of apache-tomcat intrigation?
     
  17. topdog

    topdog New Member HowtoForge Supporter

Share This Page