Getting postgresql-8.4 msg with update how to proceede

Discussion in 'Server Operation' started by Appie Thrasher, Oct 11, 2014.

  1. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    Hi All,

    probaly a very newbie question but can't figure this one out..?
    When I am updating my server (Debian Squeeze) with chanced sources.list I am getting a postgresql-8.4 msg.

    postgresql-8.4 (8.4.22-0+deb6u1) squeeze-lts; urgency=low
      8.4.22 marks the end of life of the PostgreSQL 8.4 branch. No further
      releases will be made by the PostgreSQL Global Development Group.
      Users of PostgreSQL 8.4 should look into upgrading to a newer PostgreSQL
      release. Options are:
      * Upgrading to Debian 7 (Wheezy), providing postgresql-9.1.
      * The use of the repository, providing packages for all
        active PostgreSQL branches (9.0 up to 9.4 at the time of writing).
        See for more information about the
        A helper script to activate the repository is provided in
      * An LTS version of 8.4 is in planning that will cover the lifetime of
        squeeze-lts. Updates will probably made on a best-effort basis. Users can
        take advantage of this, but should still consider upgrading to newer
        PostgreSQL versions over the next months.
     -- Christoph Berg <[email protected]>  Mon, 28 Jul 2014 19:22:43 +0200
    How do I close this one and continue the apt-get upgrade??

    Thanks for any help.

  2. srijan

    srijan New Member HowtoForge Supporter

  3. postgresql007

    postgresql007 New Member

    btw, in general it is a good idea to keep your PostgreSQL version up to date. minor releases fix bugs so it makes sense to upgrade.
    one more general issue: 8.4 is pretty old already. consider upgrading this one as well ...

Share This Page