Getting .php as source

Discussion in 'HOWTO-Related Questions' started by MarcoV, Nov 16, 2005.

  1. MarcoV

    MarcoV New Member

    I followed the perfect setup debian sarge howto today and finished it, then i installed ispconfig it was all working fine, at least until i change something in apache2.conf and restarted apache2 with /etc/init.d/apache2 restart.
    Now i am getting my .php files as the source text.

    Does someone has a solution for this problem, or now where i have to look to fix this?
  2. falko

    falko Super Moderator ISPConfig Developer

    What did you change in your apache2.conf?
  3. MarcoV

    MarcoV New Member

    To enable name look up for apache, i changed it back off but then i stell get the .php files as there source
  4. falko

    falko Super Moderator ISPConfig Developer

    Where do you see the PHP sources? In a web site you created with ISPConfig (did you enable PHP for that web site in ISPConfig?), or in a web site that existed before you installed ISPConfig?
  5. MarcoV

    MarcoV New Member

    In a website that excisted before i installed ispconfig
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig disables PHP for existing sites. Create the site in ISPConfig again and copy the contents of the existing site to the new directory created by ISPConfig.
  7. MarcoV

    MarcoV New Member

    It is working now, i have configured ispconfig and it is working like it should.
    I gues when i restarted apache to apply the changes i made he also restarted with the changes ispconfig made.

    Just wanted to say that ispconfig is very nice to work with, and it is free too:cool: !

Share This Page