getting lots of spam

Discussion in 'General' started by id10t, Oct 27, 2011.

  1. id10t

    id10t Member

    I've started to get lots of Russian spam on my ISPConfig2 set up.

    Anything I can do to eliminate it?
     
  2. till

    till Super Moderator

  3. id10t

    id10t Member

    The errors for the 'required' includes as shown below make me think that while Spamassassin is updated, it isn't running properly... time to rtfm on installing perl modules I guess...



    Code:
    # /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update -D
    [7040] dbg: logger: adding facilities: all
    [7040] dbg: logger: logging level is DBG
    [7040] dbg: generic: SpamAssassin version 3.2.5
    [7040] dbg: config: score set 0 chosen.
    [7040] dbg: dns: no ipv6
    [7040] dbg: dns: is Net::DNS::Resolver available? yes
    [7040] dbg: dns: Net::DNS version: 0.63
    [7040] dbg: generic: sa-update version svn607589
    [7040] dbg: generic: using update directory: /home/admispconfig/ispconfig/tools/spamassassin/usr/var/spamassassin/3.002005
    [7040] dbg: diag: perl platform: 5.010000 linux
    [7040] dbg: diag: module installed: Digest::SHA1, version 2.11
    [7040] dbg: diag: module installed: HTML::Parser, version 3.56
    [7040] dbg: diag: module installed: Net::DNS, version 0.63
    [7040] dbg: diag: module installed: MIME::Base64, version 3.07_01
    [7040] dbg: diag: module installed: DB_File, version 1.816_1
    [7040] dbg: diag: module installed: Net::SMTP, version 2.31
    [7040] dbg: diag: module not installed: Mail::SPF ('require' failed)
    [7040] dbg: diag: module not installed: Mail::SPF::Query ('require' failed)
    [7040] dbg: diag: module not installed: IP::Country::Fast ('require' failed)
    [7040] dbg: diag: module not installed: Razor2::Client::Agent ('require' failed)
    [7040] dbg: diag: module not installed: Net::Ident ('require' failed)
    [7040] dbg: diag: module not installed: IO::Socket::INET6 ('require' failed)
    [7040] dbg: diag: module not installed: IO::Socket::SSL ('require' failed)
    [7040] dbg: diag: module installed: Compress::Zlib, version 2.012
    [7040] dbg: diag: module installed: Time::HiRes, version 1.9711
    [7040] dbg: diag: module not installed: Mail::DomainKeys ('require' failed)
    [7040] dbg: diag: module not installed: Mail::DKIM ('require' failed)
    [7040] dbg: diag: module installed: DBI, version 1.605
    [7040] dbg: diag: module installed: Getopt::Long, version 2.37
    [7040] dbg: diag: module installed: LWP::UserAgent, version 5.834
    [7040] dbg: diag: module installed: HTTP::Date, version 5.831
    [7040] dbg: diag: module installed: Archive::Tar, version 1.38
    [7040] dbg: diag: module installed: IO::Zlib, version 1.07
    [7040] dbg: diag: module not installed: Encode::Detect ('require' failed)
    [7040] dbg: gpg: Searching for 'gpg'
    [7040] dbg: util: current PATH is: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
    [7040] dbg: util: executable for gpg was found at /usr/bin/gpg
    [7040] dbg: gpg: found /usr/bin/gpg
    [7040] dbg: gpg: release trusted key id list: 5E541DC959CB8BAC7C78DFDC4056A61A5244EC45 26C900A46DD40CD5AD24F6D7DEE01987265FA05B 0C2B1D7175B852C64B3CDC716C55397824F434CE
    [7040] dbg: channel: attempting channel updates.spamassassin.org
    [7040] dbg: channel: update directory /home/admispconfig/ispconfig/tools/spamassassin/usr/var/spamassassin/3.002005/updates_spamassassin_org
    [7040] dbg: channel: channel cf file /home/admispconfig/ispconfig/tools/spamassassin/usr/var/spamassassin/3.002005/updates_spamassassin_org.cf
    [7040] dbg: channel: channel pre file /home/admispconfig/ispconfig/tools/spamassassin/usr/var/spamassassin/3.002005/updates_spamassassin_org.pre
    [7040] dbg: channel: metadata version = 895075
    [7040] dbg: dns: 5.2.3.updates.spamassassin.org => 895075, parsed as 895075
    [7040] dbg: channel: current version is 895075, new version is 895075, skipping channel
    [7040] dbg: diag: updates complete, exiting with code 1
    
    
     
  4. till

    till Super Moderator

    There is nothing missing, the modules listed there are optional addons for spamassassin, they are not required. The "require failed" is a technical term and means "Optional module not installed".

    Spamasassin is fully installed and works fine, the relevant line is:

    diag: updates complete, exiting with code 1

    The above lines are just debug code which is enabled with the -D switch.
     

Share This Page