Getting e-mail working

Discussion in 'Installation/Configuration' started by hansoffate, Dec 13, 2006.

  1. hansoffate

    hansoffate New Member

    Sorry guys, I am really completely new to ISPConfig and sort of new to the linux hosting box setup.

    Anyways, ISPConfig is up and running and my Drupal website is working. http://hans.dnsdojo.com

    Next thing I need to do is get the e-mail servers working. How do I check if they are. I did the pkg install of roundmail. According to ispconfig my e-mail is hans@hans.dnsdojo.com
    username = web6_u1
    password = *******

    I have drupal setup to send from hans@hans.dnsdojo.com when sending e-mail. I tried registering a new user, and the e-mail never got sent. How can I get this working?

    Thanks for the help
    Hans
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please have a look at your mail.log and post the messages here that where added when you try to send a email.
     
  3. hansoffate

    hansoffate New Member

    Code:
    68.126.142.139 - - [12/Dec/2006:00:42:26 -0800] "GET / HTTP/1.1" 200 1214 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    68.126.142.139 - - [12/Dec/2006:00:42:26 -0800] "GET /favicon.ico HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    68.126.142.139 - - [12/Dec/2006:00:42:26 -0800] "GET /favicon.ico HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    66.194.6.75 - - [12/Dec/2006:02:46:41 -0800] "GET / HTTP/1.1" 200 1214 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312460)"
    68.126.142.139 - - [12/Dec/2006:08:33:16 -0800] "GET / HTTP/1.1" 304 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.213 - - [12/Dec/2006:09:32:07 -0800] "GET / HTTP/1.1" 200 1214 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.213 - - [12/Dec/2006:09:32:07 -0800] "GET /favicon.ico HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.213 - - [12/Dec/2006:09:32:08 -0800] "GET /favicon.ico HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.213 - - [12/Dec/2006:09:32:18 -0800] "GET /favicon.ico HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.213 - - [12/Dec/2006:09:32:18 -0800] "GET /favicon.ico HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.213 - - [12/Dec/2006:09:32:20 -0800] "GET /favicon.ico HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.213 - - [12/Dec/2006:09:32:35 -0800] "GET /favicon.ico HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.213 - - [12/Dec/2006:09:36:21 -0800] "GET / HTTP/1.1" 200 1214 "-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 2.0.50727)"
    169.237.125.194 - - [12/Dec/2006:10:26:19 -0800] "GET / HTTP/1.1" 200 1214 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.194 - - [12/Dec/2006:10:26:19 -0800] "GET /favicon.ico HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:10:43:48 -0800] "GET / HTTP/1.1" 304 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:10:43:54 -0800] "GET /web HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:10:45:01 -0800] "GET /~hans HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:10:45:06 -0800] "GET /users/hans HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:10:45:10 -0800] "GET /users HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:11:01:24 -0800] "GET /index.php HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:11:01:54 -0800] "GET /install.php HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:11:02:01 -0800] "GET /install.txt HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:11:02:03 -0800] "GET /install.txt HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:11:02:22 -0800] "GET /web HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:11:49:08 -0800] "GET / HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:11:49:13 -0800] "GET / HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:11:54:32 -0800] "GET / HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:11:54:42 -0800] "GET / HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:11:56:30 -0800] "GET / HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:11:58:17 -0800] "GET / HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:12:10:43 -0800] "GET /web HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:12:10:46 -0800] "GET /web/ HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:12:10:48 -0800] "GET /web1 HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:12:10:51 -0800] "GET / HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:12:11:26 -0800] "GET / HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:12:11:27 -0800] "GET / HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:12:12:32 -0800] "GET / HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:12:12:33 -0800] "GET / HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:12:36:01 -0800] "GET / HTTP/1.1" 200 1214 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    169.237.125.193 - - [12/Dec/2006:12:51:50 -0800] "GET / HTTP/1.1" 200 1214 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    87.122.70.11 - - [12/Dec/2006:13:45:58 -0800] "GET / HTTP/1.1" 200 1214 "http://www.howtoforge.com/forums/showthread.php?p=52276" "Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    87.122.70.11 - - [12/Dec/2006:13:45:59 -0800] "GET /favicon.ico HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    87.122.70.11 - - [12/Dec/2006:13:45:59 -0800] "GET /favicon.ico HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    84.62.18.208 - - [12/Dec/2006:13:53:16 -0800] "GET / HTTP/1.1" 200 1214 "-" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X; de-de) AppleWebKit/418.9.1 (KHTML, like Gecko) Safari/419.3"
    84.62.18.208 - - [12/Dec/2006:13:53:17 -0800] "GET /favicon.ico HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X; de-de) AppleWebKit/418.9.1 (KHTML, like Gecko) Safari/419.3"
    206.207.108.121 - - [12/Dec/2006:14:28:15 -0800] "GET / HTTP/1.1" 200 1214 "http://www.howtoforge.com/forums/showthread.php?t=9049" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060913 Fedora/1.5.0.7-1.fc5 Firefox/1.5.0.7 pango-text"
    206.207.108.121 - - [12/Dec/2006:14:28:15 -0800] "GET /favicon.ico HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060913 Fedora/1.5.0.7-1.fc5 Firefox/1.5.0.7 pango-text"
    128.211.191.32 - - [12/Dec/2006:14:31:53 -0800] "GET / HTTP/1.1" 200 1214 "http://www.howtoforge.com/forums/showthread.php?p=52276" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"
    
    I am not really sure how to test this. I havn't been able to figure out how to configure this or how to access the roundcube mail i installed. I don't know what the pop3 or smtp or whatever settings to use.

    Thank you for helping out a newb.
    Hans
     
    Last edited: Dec 14, 2006
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The above output is from your apache logfile and not from your mail logfile. Please post a excerpt of the mail log.
     
  5. hansoffate

    hansoffate New Member

    That log file was from /var/www/web6/log/mail.log Where is the mail log your talking about?

    Thanks for the help
    -Hans
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    The mail log is in /var/log.
     
  7. hansoffate

    hansoffate New Member

    Code:
    Dec 14 12:29:04 hans postfix/qmgr[331]: B88801410403: from=<www-data@hans.dnsdojo.com>, size=1367, nrcpt=1 (queue active)
    Dec 14 12:29:34 hans postfix/smtp[30162]: connect to gmail-smtp-in.l.google.com[72.14.215.114]: Connection timed out (port 25)
    Dec 14 12:30:04 hans postfix/smtp[30162]: connect to gmail-smtp-in.l.google.com[72.14.215.27]: Connection timed out (port 25)
    Dec 14 12:30:34 hans postfix/smtp[30162]: connect to alt1.gmail-smtp-in.l.google.com[72.14.205.27]: Connection timed out (port 25)
    Dec 14 12:31:04 hans postfix/smtp[30162]: connect to alt2.gmail-smtp-in.l.google.com[64.233.167.114]: Connection timed out (port 25)Dec 14 12:31:34 hans postfix/smtp[30162]: connect to alt2.gmail-smtp-in.l.google.com[64.233.167.27]: Connection timed out (port 25)Dec 14 12:31:34 hans postfix/smtp[30162]: B88801410403: to=<hansoff87@gmail.com>, relay=none, delay=92756, delays=92605/0.03/150/0, dsn=4.4.1, status=deferred (connect to alt2.gmail-smtp-in.l.google.com[64.233.167.27]: Connection timed out)
    Dec 14 13:02:24 hans postfix/qmgr[331]: 0208B14103FB: from=<www-data@hans.dnsdojo.com>, size=667, nrcpt=1 (queue active)
    Dec 14 13:02:24 hans postfix/qmgr[331]: 2FF181410407: from=<www-data@hans.dnsdojo.com>, size=1346, nrcpt=1 (queue active)
    Dec 14 13:02:54 hans postfix/smtp[31365]: connect to gmail-smtp-in.l.google.com[66.249.93.114]: Connection timed out (port 25)
    Dec 14 13:02:54 hans postfix/smtp[31366]: connect to gmail-smtp-in.l.google.com[66.249.93.27]: Connection timed out (port 25)
    Dec 14 13:03:24 hans postfix/smtp[31365]: connect to gmail-smtp-in.l.google.com[66.249.93.27]: Connection timed out (port 25)
    Dec 14 13:03:24 hans postfix/smtp[31366]: connect to gmail-smtp-in.l.google.com[66.249.93.114]: Connection timed out (port 25)
    Dec 14 13:03:54 hans postfix/smtp[31365]: connect to alt2.gmail-smtp-in.l.google.com[64.233.163.114]: Connection timed out (port 25)
    Dec 14 13:03:54 hans postfix/smtp[31366]: connect to alt2.gmail-smtp-in.l.google.com[64.233.163.27]: Connection timed out (port 25)
    Dec 14 13:04:24 hans postfix/smtp[31365]: connect to alt1.gmail-smtp-in.l.google.com[209.85.133.27]: Connection timed out (port 25)
    Dec 14 13:04:24 hans postfix/smtp[31366]: connect to alt2.gmail-smtp-in.l.google.com[64.233.163.114]: Connection timed out (port 25)
    Dec 14 13:04:54 hans postfix/smtp[31365]: connect to alt2.gmail-smtp-in.l.google.com[64.233.163.27]: Connection timed out (port 25)Dec 14 13:04:54 hans postfix/smtp[31366]: connect to alt1.gmail-smtp-in.l.google.com[209.85.133.27]: Connection timed out (port 25)Dec 14 13:04:54 hans postfix/smtp[31365]: 0208B14103FB: to=<hansoffate@gmail.com>, relay=none, delay=97890, delays=97740/0.04/150/0, dsn=4.4.1, status=deferred (connect to alt2.gmail-smtp-in.l.google.com[64.233.163.27]: Connection timed out)Dec 14 13:04:54 hans postfix/smtp[31366]: 2FF181410407: to=<jjgsmail@gmail.com>, relay=none, delay=77904, delays=77753/0.03/150/0, dsn=4.4.1, status=deferred (connect to alt1.gmail-smtp-in.l.google.com[209.85.133.27]: Connection timed out)
    Dec 14 13:52:24 hans postfix/qmgr[331]: B88801410403: from=<www-data@hans.dnsdojo.com>, size=1367, nrcpt=1 (queue active)Dec 14 13:52:54 hans postfix/smtp[708]: connect to gmail-smtp-in.l.google.com[72.14.215.27]: Connection timed out (port 25)
    Dec 14 13:53:24 hans postfix/smtp[708]: connect to gmail-smtp-in.l.google.com[72.14.215.114]: Connection timed out (port 25)Dec 14 13:53:54 hans postfix/smtp[708]: connect to alt1.gmail-smtp-in.l.google.com[72.14.205.27]: Connection timed out (port 25)
    Dec 14 13:54:24 hans postfix/smtp[708]: connect to alt2.gmail-smtp-in.l.google.com[64.233.167.27]: Connection timed out (port 25)
    Dec 14 13:54:54 hans postfix/smtp[708]: connect to alt2.gmail-smtp-in.l.google.com[64.233.167.114]: Connection timed out (port 25)Dec 14 13:54:54 hans postfix/smtp[708]: B88801410403: to=<hansoff87@gmail.com>, relay=none, delay=97756, delays=97605/0.03/150/0, dsn=4.4.1, status=deferred (connect to alt2.gmail-smtp-in.l.google.com[64.233.167.114]: Connection timed out)
    Dec 14 14:25:44 hans postfix/qmgr[331]: 0208B14103FB: from=<www-data@hans.dnsdojo.com>, size=667, nrcpt=1 (queue active)
    Dec 14 14:25:44 hans postfix/qmgr[331]: 2FF181410407: from=<www-data@hans.dnsdojo.com>, size=1346, nrcpt=1 (queue active)
    Dec 14 14:26:14 hans postfix/smtp[1920]: connect to gmail-smtp-in.l.google.com[64.233.183.27]: Connection timed out (port 25)
    Dec 14 14:26:19 hans postfix/smtp[1921]: connect to gmail-smtp-in.l.google.com[64.233.183.27]: Connection timed out (port 25)
    Dec 14 14:26:44 hans postfix/smtp[1920]: connect to gmail-smtp-in.l.google.com[64.233.183.114]: Connection timed out (port 25)
    Dec 14 14:26:49 hans postfix/smtp[1921]: connect to gmail-smtp-in.l.google.com[64.233.183.114]: Connection timed out (port 25)Dec 14 14:27:14 hans postfix/smtp[1920]: connect to alt1.gmail-smtp-in.l.google.com[72.14.215.27]: Connection timed out (port 25)
    Dec 14 14:27:19 hans postfix/smtp[1921]: connect to alt1.gmail-smtp-in.l.google.com[72.14.215.114]: Connection timed out (port 25)
    Dec 14 14:27:44 hans postfix/smtp[1920]: connect to alt2.gmail-smtp-in.l.google.com[72.14.205.27]: Connection timed out (port 25)
    Dec 14 14:27:49 hans postfix/smtp[1921]: connect to alt1.gmail-smtp-in.l.google.com[72.14.215.27]: Connection timed out (port 25)
    Dec 14 14:28:14 hans postfix/smtp[1920]: connect to alt1.gmail-smtp-in.l.google.com[72.14.215.114]: Connection timed out (port 25)Dec 14 14:28:14 hans postfix/smtp[1920]: 0208B14103FB: to=<hansoffate@gmail.com>, relay=none, delay=102890, delays=102740/0.04/150/0, dsn=4.4.1, status=deferred (connect to alt1.gmail-smtp-in.l.google.com[72.14.215.114]: Connection timed out)
    Dec 14 14:28:19 hans postfix/smtp[1921]: connect to alt2.gmail-smtp-in.l.google.com[72.14.205.27]: Connection timed out (port 25)Dec 14 14:28:19 hans postfix/smtp[1921]: 2FF181410407: to=<jjgsmail@gmail.com>, relay=none, delay=82909, delays=82753/0.03/155/0, dsn=4.4.1, status=deferred (connect to alt2.gmail-smtp-in.l.google.com[72.14.205.27]: Connection timed out)
    Dec 14 15:15:44 hans postfix/qmgr[331]: B88801410403: from=<www-data@hans.dnsdojo.com>, size=1367, nrcpt=1 (queue active)
    Dec 14 15:16:14 hans postfix/smtp[3742]: connect to gmail-smtp-in.l.google.com[72.14.215.114]: Connection timed out (port 25)
    Dec 14 15:16:44 hans postfix/smtp[3742]: connect to gmail-smtp-in.l.google.com[72.14.215.27]: Connection timed out (port 25)
    Dec 14 15:17:14 hans postfix/smtp[3742]: connect to alt2.gmail-smtp-in.l.google.com[72.14.215.114]: Connection timed out (port 25)Dec 14 15:17:44 hans postfix/smtp[3742]: connect to alt2.gmail-smtp-in.l.google.com[72.14.215.27]: Connection timed out (port 25)
    Dec 14 15:18:14 hans postfix/smtp[3742]: connect to alt1.gmail-smtp-in.l.google.com[72.14.205.27]: Connection timed out (port 25)Dec 14 15:18:14 hans postfix/smtp[3742]: B88801410403: to=<hansoff87@gmail.com>, relay=none, delay=102756, delays=102605/0.03/150/0, dsn=4.4.1, status=deferred (connect to alt1.g
    There is a section of my log. I have a feeling i configured it wrong.

    What should i do?

    Thank you for the help
    -Hans
     
  8. edge

    edge Active Member Moderator HowtoForge Supporter

    Looks like your ISP is blocking port 25.
    Get an other ISP, or use the mailserver from your ISP.

    **edit**

    Your ISP is PacBell (pacbell.net) right?

    If so,
    Find the full list here.
     
    Last edited: Dec 15, 2006
  9. hansoffate

    hansoffate New Member

    edge - you are probably correct. My acutal e-mail adress from my isp is hansoffate@sbcglobal.net.

    If you wouldn't mind me asking, How would I set this up to make it use that (since that is what you suggested). I set it up in postfix? or in drupal?

    Thanks for the help
    -Hans
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    To route the email trough the mailserver of your ISP, set the relayhost directive in your postfix main.cf to the mailrelay server of your ISP and restart postfix.
     
  11. hansoffate

    hansoffate New Member

    I found the main.cf here is the seciton of it that I think you are talking about.

    Code:
    myhostname = hans.dnsdojo.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = hans.dnsdojo.com, localhost.dnsdojo.com, , localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    
    What should i change? should i change relayhost to mailhost? How do I find out what I need to put in there? I have att dsl. my e-mail is hansoffate@sbcglobal.net.

    Thanks for the help,
    -Hans
     
  12. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  13. hansoffate

    hansoffate New Member

    I followed your 2 posts for that guy. I used the smtp and pop from sbcglobal.net I also added the relayhost.

    Here is my mail.log after trying to register a new user for my website.

    Code:
    Dec 16 10:52:29 hans postfix/anvil[29558]: statistics: max connection rate 1/60s for (smtp:192.168.1.100) at Dec 16 10:49:09
    Dec 16 10:52:29 hans postfix/anvil[29558]: statistics: max connection count 1 for (smtp:192.168.1.100) at Dec 16 10:49:09
    Dec 16 10:52:29 hans postfix/anvil[29558]: statistics: max cache size 1 at Dec 16 10:49:09
    Dec 16 10:53:45 hans postfix/pickup[29529]: E7517141054D: uid=33 from=<www-data>
    Dec 16 10:53:45 hans postfix/cleanup[29729]: E7517141054D: message-id=<20061216185345.E7517141054D@hans.dnsdojo.com>
    Dec 16 10:53:46 hans postfix/qmgr[29530]: E7517141054D: from=<www-data@hans.dnsdojo.com>, size=1367, nrcpt=1 (queue active)Dec 16 10:53:47 hans postfix/smtp[29731]: E7517141054D: to=<hansoff87@gmail.com>, relay=smtp.sbcglobal.yahoo.com[68.142.198.11]:25, delay=1.1, delays=0.1/0.24/0.81/0, dsn=5.0.0, status=bounced (SASL authentication failed; server smtp.sbcglobal.yahoo.com[68.142.198.11] said: 535 authorization failed (#5.7.0))Dec 16 10:53:47 hans postfix/cleanup[29729]: 162CC141054F: message-id=<20061216185347.162CC141054F@hans.dnsdojo.com>
    Dec 16 10:53:47 hans postfix/qmgr[29530]: 162CC141054F: from=<>, size=3301, nrcpt=1 (queue active)
    Dec 16 10:53:47 hans postfix/local[29734]: warning: database /etc/aliases.db is older than source file /etc/aliasesDec 16 10:53:47 hans postfix/bounce[29733]: E7517141054D: sender non-delivery notification: 162CC141054F
    Dec 16 10:53:47 hans postfix/qmgr[29530]: E7517141054D: removedDec 16 10:53:48 hans postfix/local[29734]: 162CC141054F: to=<www-data@hans.dnsdojo.com>, relay=local, delay=1.1, delays=0.02/0.01/0/1, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
    Dec 16 10:53:48 hans postfix/qmgr[29530]: 162CC141054F: removed
    
    Thanks for all the help
    -Hans
     
  14. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You used a relayserver (smtp.sbcglobal.yahoo.com) that needs smtp authentication to relay ,mails trough it. You will have to configure your postfix to send authentication information.
     
  15. hansoffate

    hansoffate New Member

    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    "main.cf" 58 lines, 1856 characters
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version


    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    myhostname = hans.dnsdojo.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = hans.dnsdojo.com, localhost.dnsdojo.com, , localhost
    relayhost = smtp.sbcglobal.yahoo.com
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names
    smtp_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    smtp_sasl_security_options =

    That is my main.cf

    Is there something wrong there?

    Thank you
    -Hans
     
  16. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Do you have the correct username and password in /etc/postfix/sasl_passwd? Did you run
    Code:
    postmap /etc/postfix/sasl_passwd
    /etc/init.d/postfix restart
    ?
     
  17. hansoffate

    hansoffate New Member

    Thanks. That fixed it. I forgot to do the postmap command after I changed the file.

    New user registration is now working with my site! Thank you!
    -Hans
     
  18. bwrob

    bwrob New Member

    I go around my isp blocking port 25 and use port 587.
    Need to set it up in postfix master.cf.

    smtps inet n - n - - smtpd -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
    587 inet n - n - - mtpd -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes

    bob
     
  19. vijay_ps

    vijay_ps New Member

    send mail is working properly

    Dear Sir,
    I am trying to send mails from my website hosted on a linux web server but it is not working.

    Please see mail log and tell me what can be the problem and also why it is repeatedly sending mails.
    ==========================================================
    Jul 30 05:45:01 rks sendmail[17139]: m6U0F1qK017139: from=root, size=401, class=0, nrcpts=1, msgid=<200807300015.m6U0F1qK017139@rks.hpitr.com>, relay=root@localhost
    Jul 30 05:45:01 rks sendmail[17140]: m6U0F1W7017140: tcpwrappers (rks.hpitr.com, 127.0.0.1) rejection
    Jul 30 05:45:01 rks sendmail[17139]: m6U0F1qK017139: to=root, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30401, relay=[127.0.0.1] [127.0.0.1], dsn=5.0.0, stat=Service unavailable
    Jul 30 05:45:01 rks sendmail[17139]: m6U0F1qK017139: m6U0F1qL017139: DSN: Service unavailable
    Jul 30 05:45:01 rks sendmail[17139]: m6U0F1qL017139: to=root, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=31425, relay=[127.0.0.1], dsn=5.0.0, stat=Service unavailable
    Jul 30 05:45:01 rks sendmail[17139]: m6U0F1qL017139: m6U0F1qM017139: return to sender: Service unavailable
    Jul 30 05:45:01 rks sendmail[17139]: m6U0F1qM017139: to=postmaster, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=32449, relay=[127.0.0.1], dsn=5.0.0, stat=Service unavailable
    Jul 30 05:45:01 rks sendmail[17139]: m6U0F1qL017139: Losing ./qfm6U0F1qL017139: savemail panic
    Jul 30 05:45:01 rks sendmail[17139]: m6U0F1qL017139: SYSERR(root): savemail: cannot save rejected email anywhere
    Jul 30 05:46:02 rks sendmail[17156]: m6U0G2Oo017156: from=root, size=401, class=0, nrcpts=1, msgid=<200807300016.m6U0G2Oo017156@rks.hpitr.com>, relay=root@localhost
    Jul 30 05:46:02 rks sendmail[17157]: m6U0G2ph017157: tcpwrappers (rks.hpitr.com, 127.0.0.1) rejection
    Jul 30 05:46:02 rks sendmail[17156]: m6U0G2Oo017156: to=root, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30401, relay=[127.0.0.1] [127.0.0.1], dsn=5.0.0, stat=Service unavailable
    Jul 30 05:46:02 rks sendmail[17156]: m6U0G2Oo017156: m6U0G2Op017156: DSN: Service unavailable
    Jul 30 05:46:02 rks sendmail[17156]: m6U0G2Op017156: to=root, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=31425, relay=[127.0.0.1], dsn=5.0.0, stat=Service unavailable
    Jul 30 05:46:02 rks sendmail[17156]: m6U0G2Op017156: m6U0G2Oq017156: return to sender: Service unavailable
    Jul 30 05:46:02 rks sendmail[17156]: m6U0G2Oq017156: to=postmaster, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=32449, relay=[127.0.0.1], dsn=5.0.0, stat=Service unavailable
    Jul 30 05:46:02 rks sendmail[17156]: m6U0G2Op017156: Losing ./qfm6U0G2Op017156: savemail panic
    Jul 30 05:46:02 rks sendmail[17156]: m6U0G2Op017156: SYSERR(root): savemail: cannot save rejected email anywhere
    Jul 30 05:47:01 rks sendmail[17173]: m6U0H1el017173: from=root, size=401, class=0, nrcpts=1, msgid=<200807300017.m6U0H1el017173@rks.hpitr.com>, relay=root@localhost
    Jul 30 05:47:01 rks sendmail[17174]: m6U0H17o017174: tcpwrappers (rks.hpitr.com, 127.0.0.1) rejection
    Jul 30 05:47:01 rks sendmail[17173]: m6U0H1el017173: to=root, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30401, relay=[127.0.0.1] [127.0.0.1], dsn=5.0.0, stat=Service unavailable
    Jul 30 05:47:01 rks sendmail[17173]: m6U0H1el017173: m6U0H1em017173: DSN: Service unavailable
    Jul 30 05:47:01 rks sendmail[17173]: m6U0H1em017173: to=root, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=31425, relay=[127.0.0.1], dsn=5.0.0, stat=Service unavailable
    Jul 30 05:47:01 rks sendmail[17173]: m6U0H1em017173: m6U0H1en017173: return to sender: Service unavailable
    Jul 30 05:47:01 rks sendmail[17173]: m6U0H1en017173: to=postmaster, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=32449, relay=[127.0.0.1], dsn=5.0.0, stat=Service unavailable
    Jul 30 05:47:01 rks sendmail[17173]: m6U0H1em017173: Losing ./qfm6U0H1em017173: savemail panic
    Jul 30 05:47:01 rks sendmail[17173]: m6U0H1em017173: SYSERR(root): savemail: cannot save rejected email anywhere
    Jul 30 05:48:01 rks sendmail[17192]: m6U0I1s6017192: from=root, size=401, class=0, nrcpts=1, msgid=<200807300018.m6U0I1s6017192@rks.hpitr.com>, relay=root@localhost
    Jul 30 05:48:01 rks sendmail[17193]: m6U0I1IF017193: tcpwrappers (rks.hpitr.com, 127.0.0.1) rejection
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++
    Please see the above log and tell us the possible reason. I am using Red hat enterprise linux version 4
     
  20. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ?
    What's in /etc/hosts.deny?
     

Share This Page