getting dependency errors on libmysqlclient install

Discussion in 'Installation/Configuration' started by dagg, Sep 6, 2008.

  1. dagg

    dagg New Member

    im getting the following error during the debian 4 install walkthrough

    The following packages have unmet dependencies:
    libmysqlclient15-dev: Depends: zlib1g-dev but it is not going to be installed
    E: Broken packages


    what i dont get is the following:
    just for kicks i tried installing zlib1g-dev via apt-get and got the following

    The following packages have unmet dependencies:
    zlib1g-dev: Depends: zlib1g (= 1:1.2.3-13) but 1:1.2.3.3.dfsg-7ubuntu1 is to be installed
    Depends: libc6-dev but it is not going to be installed or
    libc-dev

    im running debian 4.0.... why is this referencing ubuntu?

    something is very wrong and im not sure what exactly that is as im not very knowledgeable with linux... can someone lend me a hand here?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the content of /etc/apt/sources.list
     
  3. dagg

    dagg New Member

  4. dagg

    dagg New Member

    also, i talked to one of my IS guys who has installed ISPconfig before and he said i could skip the dev packages... which i did.

    *edit*
    so i have gotten through the server config but i can see that i cant actually skip the dev packages as they are required for the install.

    so now im stuck until i solve the problem of why im having dependency problems
     
    Last edited: Sep 6, 2008
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The dev packages wont be listed in the guide if they can be skipped.

    The sources list looks correct.

    Please run:

    apt-get update
    apt-get -u upgrade

    and then try again:

    apt-get install libmysqlclient15-dev
     
  6. dagg

    dagg New Member

    i have already done the update and upgrade... getting the same thing.

    Went back to my IS guy (who unfortunately didnt have time to work on any of this at the time) and he says that i dont have ANY dev packages installed and thats where the problem is coming from.

    this was a base install of debian4.0...

    if thats the case, how do i get the dev packages installed?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The current problem is not that no dev packages are installed, the problem is the installation of the dev packages. Your linux system seems to be broken, it looks as someone installed ubuntu packages on it so the system is a mixed up ubuntu / debian system now which causes dependency errors.

    apt-get install libmysqlclient15-dev
     
  8. dagg

    dagg New Member

    ok.. so other than just using apt-get to try and get the package, how do i fix the dependency problems? apt-get is not going to work in this case because of the messed up dependencies so mearly trying to apt-get the specific packages is not going to work.... the dependency problem and however this got messed up has to get fixed first
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Did your sources.list always look like that, or did you have some other repositories in it (like from Ubuntu)?
     

Share This Page