getting a "forbidden" error 403 when accessing any other page than ISPconfig panel.

Discussion in 'General' started by neumann, Aug 27, 2012.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    It uses ubuntus default vhost, but as I explained in one of my first posts, apache priorizes IP addresses in favor of wildcards, so it can be that a vhost which uses a IP address is shown befaore the default vhost. The solutions are:

    a) Use * for all sites instaed of IP addresses.
    b) Create a additional default vhost for each IP address.
  2. neumann

    neumann New Member

    There is only one vhost, and it is allready * marked
    There is only one ip address. So there is no need to make an extra vhost.

    I tried yesterday to point the DNS at this server again, with the right domain, but still there was the forbidden message this morning (after the DNS has probagated through all the DNS servers in the chain). So since it's a production site, I have switched the DNS back to point at another server.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    To test the website without changing the dns record use this method:

    Changing the hosts file on your workstation affects only the applications that you run on your workstation, so you can test out the settings for a production side withou affecting any customers. Another psotive side affect is that you can do the test in realtime without having to with for the dns caches to change.
  4. neumann

    neumann New Member

    Nice to know, but not a solution to the problem at hand.

    The problem is that apache does not serve either the default webpage nor a vhost page set up in ISPconfig. It serves a message "forbidden"
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Just to close the issue, the server is behind a nat router and the vhost was configured to use the external ip address instead of the internal ip so apache could not find a matching vhost for the domain / ip combination.

    General note for servers behind a router:

    In websites (vhosts) use the internal ip address
    For dns records (bind) use the external ip
  6. neumann

    neumann New Member

    First off. I'm really glad for the support here. Thats what makes worth installing such a great tool as ISPConfig3.

    Sorry that I haven't answered before, but I've been busy testing the server, and yesterday I wasn't really happy - cause it didn't work.

    But today I have the first and most important page up and running.

    I'm not really sure that the default works. But now that the important page is running I'm sure the rest will work eventually.

    First I'll try out the class 1 certificate to get rid of the warning about entering an unsecure site when wanting to log in to ISPConfig3 over https.

    Secondly I'll try to install roundcube instead of squirrelmail. I think it has a "nicer touch" and "look" than squirrelmail.

    I allready bought the ISPConfig 3 manual, some year ago. But I think it's been updated so it might be worth buying the current manual. :)

    Thanks for now Till
  7. toughguy

    toughguy New Member

    fcgid might cause 503 trouble as well

    hey folks, I ran into a similar problem with a fresh install which kept giving me 403 errors whenever I tried to access the admin panel for the first time.

    In my case the culprit has been the missing fcgid module.
    Once I installed it using

    apt-get install libapache2-mod-fcgid

    followed by a restart of apache everything worked like a charm :)

    Last edited: May 14, 2014

Share This Page