getmail.sh Cron job fails?

Discussion in 'Server Operation' started by KZeeSoft, Mar 27, 2010.

  1. KZeeSoft

    KZeeSoft New Member

    [SOLVED] getmail.sh Cron job fails?

    I get this information from my ISPC-Log and wonder what the problem is? Is this normal?

    I noticed a problem where my php scripts will not send mail to the server, can this be related somehow?


    Code:
    /bin/sh: /usr/local/ispconfig/server/scripts/run-getmail.sh: Permission denied
    /bin/sh: /usr/local/ispconfig/server/scripts/run-getmail.sh: Permission denied
    /bin/sh: /usr/local/ispconfig/server/scripts/run-getmail.sh: Permission denied
    ln: creating symbolic link `/var/www/clients/client1/sufuku.net': No such file or directory
    chmod: cannot access `/var/www/clients/client0/web1/*': No such file or directory
    
     
    Last edited: Mar 29, 2010
  2. falko

    falko Super Moderator

    Any errors in your mail log?
     
  3. KZeeSoft

    KZeeSoft New Member

    Hey Falko!

    Good to hear from ya =)

    Actually, I just figured this issue out:

    -I had email forward rules set in my ISP Config 3 panel, and were working fine.
    -I upgraded to the new ISP Config 3 last week, and didnt think about the forwarding.
    -I was testing my new php scripts (contact forms) and saw they were not working, and couldn't figure out why, until I noticed my mail wasn't working either!
    -I did some more digging, and found out that email forwarding is not working properly.

    SO! The issue was email forwarding was setup, and the PHP scripts were actually fine, just that the email was being "digitally lost" because of the upgrade to the newest ISP Config.
     

Share This Page