getmail+postfix are relaying to cc-ed recipients

Discussion in 'Server Operation' started by matty, Apr 15, 2010.

  1. matty

    matty Member

    I'm setting up an ISPConfig3 server for a small business to use. It's really nice. Thanks! :D

    The only thing that is giving me trouble is they currently get all mail delivered to a single mailbox at their current webhost. They'd like to keep that working for various, unimportant reasons.

    So, I have set up getmail to retrieve the mail from that webhost and deliver it to the separate local user mailboxes. That works fine, except.. What I'm finding is that getmail looks at the recipient list, delivers to the local recipient/s, and also sends a copy of the email to any other non-local recipients that may be cc:-ed. Obviously, this is not a good thing to do. I'm not sure how to deal with this.

    Here is my getmail .conf contents. Other than having set up a user, domain, and mailboxes in ISPConfig, it's all essentially default install on Debian Lenny.

    Code:
    [options]
    message_log_syslog = 1
    delete = 0
    delivered_to = false
    
    [retriever]
    type = MultidropPOP3Retriever
    server = pop3.example.com
    username = user@example.com
    password = thepassword
    envelope_recipient = Envelope-to:1
    
    [destination]
    type = MDA_external
    path = /usr/sbin/sendmail
    arguments = ("-i", "-bm", "-t")
    unixfrom = true
    
     
  2. matty

    matty Member

    Problem solved. It was my own mistake. Don't use "sendmail -t" to reinject mail. :eek:

    Here is the new, working getmail config for sake of searches. Please note that the "delete = 0" is because I currently want to leave messages on the remote server.

    Code:
    [options]
    message_log_syslog = 1
    delete = 0
    delivered_to = false
    
    [retriever]
    type = MultidropPOP3Retriever
    server = pop3.example.com
    username = user@example.com
    password = thepassword
    envelope_recipient = Envelope-to:1
    
    [destination]
    type = MDA_external
    path = /usr/sbin/sendmail
    arguments = ("-i", "-bm", "%(recipient)")
    unixfrom = true
    
     
    Last edited: Apr 16, 2010

Share This Page