Getmail does an does not do it :?

Discussion in 'Installation/Configuration' started by Grom, Mar 28, 2009.

  1. Grom

    Grom New Member

    I installed ISPconfig on my server with teh perfect server howto i found here

    http://www.howtoforge.org/perfect-server-debian-lenny-ispconfig3-p1

    It worked like a charm and out of the box, thanks for the good work!


    but ....


    I dont seem to get "getmail" working.

    What i have done so far.

    1) Looked in de logfile

    Every 5 minutes there comes a line in the logfile "/var/log/ispconfig/cron.log" that says:

    "/bin/sh: /usr/local/ispconfig/server/scripts/run-getmail.sh: Permission denied"

    The file cron.log is chmodded 666.


    2) Ran /usr/local/ispconfig/server/scripts/run-getmail.sh as root. It then runs fine.
    run-getmail is chmodded 755.


    3) searched internet and found someone posting a similar prolem but the suggested solution didn't work for me.
    the link: http://bugtracker.ispconfig.org/index.php?do=details&task_id=484
    see the Comment by Paolo (airton)

    Perhaps it has something to do with the crontab that triggers the event every 5 minutes but i cant seem to find it.

    Can anyone help?

    Greetz,

    Grom
     
    Last edited: Mar 28, 2009
  2. till

    till Super Moderator

  3. phorce1

    phorce1 New Member

    I used update_from_svn.sh and the problem still exists here.

    What was the fix so I can adjust it manually? I'm going to need it very soon. All of the permissions look correct.

    Other changes that should be made to the getmail section to allow retrieving from servers like gmail that force ssl:

    /usr/local/interface/web/mail/form/mail_get.tform.php

    Line 76 from
    Code:
                             'value'         => array('pop3' => 'POP3','imap'=>'IMAP')
    
    to
    Code:
                            'value'         => array('pop3' => 'POP3','imap'=>'IMAP','pop3ssl' => 'POP3SSL','imapssl'=>'IMAPSSL')
    
    and /usr/local/ispconfig/server/plugins-enabled/getmail_plugin.inc.php

    starting at line 112

    Code:
                                    // Set the data retriever
                                    if($data["new"]["type"] == 'pop3') {
                                            $tpl = str_replace('{TYPE}','SimplePOP3Retriever',$tpl);
                                    } elseif ($data["new"]["type"] == 'imap') {
                                            $tpl = str_replace('{TYPE}','SimpleIMAPRetriever',$tpl);
                                    }
    
    change to

    Code:
                                    // Set the data retriever
                                    if($data["new"]["type"] == 'pop3') {
                                            $tpl = str_replace('{TYPE}','SimplePOP3Retriever',$tpl);
                                    } elseif ($data["new"]["type"] == 'imap') {
                                            $tpl = str_replace('{TYPE}','SimpleIMAPRetriever',$tpl);
                                    } elseif ($data["new"]["type"] == 'pop3ssl') {
                                            $tpl = str_replace('{TYPE}','SimplePOP3SSLRetriever',$tpl);
                                    } elseif ($data["new"]["type"] == 'imapssl') {
                                            $tpl = str_replace('{TYPE}','SimpleIMAPSSLRetriever',$tpl);
                                    }
    
     
  4. till

    till Super Moderator

    The changes you posted above are not related to the problem. Please install the latest ispconfig 3 version and choose to reconfigure services during update. This will definately fix it.
     
  5. phorce1

    phorce1 New Member

    I know those changes weren't related, I just didn't know of another place to mention them as a "good idea" to add.

    And, yes, the update not working was my error. I ran update_from_svn.sh directly rather than running ispconfig_update.sh and selecting the 'svn' option.

    It is working now after doing the svn update the correct way.

    Thank you,

    Gerald
     
  6. till

    till Super Moderator

    For feature requests please use the feature request function of the bugtracker:

    http://bugtracker.ispconfig.org
     
  7. reason8

    reason8 New Member

    I have this error also. I am using ISPConfig3 3.0.1.6. My ISP Cron-log is full of "/bin/sh: /usr/local/ispconfig/server/scripts/run-getmail.sh: Permission denied"

    How do I resolve this problem?
     
  8. till

    till Super Moderator

    Rerun the ispconfig update and choose to reconfigure the cronjobs.
     
  9. reason8

    reason8 New Member


    Stable and not SVN correct?

    Also, when I looked got run-getmail.sh, it is not located in the /usr/local/ispconfig/server/scripts/ but there is a getmail.sh. On the other hand run-getmail.sh is located at /usr/local/bin/run-getmail.sh

    Is this the problem? Will running the update fix this? I have updated ISPConfig3 before a month ago and a few updates before. Shouldn't this have fixed the problem? Just wondering.

    Thanks!
     
  10. till

    till Super Moderator

    yes.

    You run the updates but you did not choose to reconfigure the cronjobs. Run the update again choose y when the updater asks if the cronjobs shall be reconfigured.
     

Share This Page