General Question about Webserver and the updates

Discussion in 'Installation/Configuration' started by iceget, Mar 2, 2016.

  1. iceget

    iceget Member

    dear team,

    currently i have running 2 servers (years ago) now, we need a new php version.
    so now, its time for a new server, or? the running 2 webservers hase a load from 10%...

    my question is:
    is it possible to install a server this keeps automatic updated (side from operating system, and php)?

    currently my old webserver has installed squeeze with the current ispconfig version.

    the mainproblem is the php version. typo3 needs the new php, but on my old debian webserver only 5.2 is supported (must do a dist-upgrade to a newer one). and there is my problem: many old webs will crash (functions deprecated)..

    is that correct? i dont want install a new webserver too... otherwise i have in 10 years 4 webservers, with no load...

    i have read that cloudlinux and plesk or cpanel should do this, what i need. is that correct?
    i think a system where i can change without problems php versions (old and new, with the same server).

    has anybody a recommendation for me what i can do? now its time for a new php version for typo3 (the need them).

    thanks and many greets
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Debian has an automatic updater if you want to install the security updates and you can run multiple php versions in ISPConfig easily and independatly from thephp version of the OS, see ISPConfig PHP installation tutorials.

    That's exactly what ISPConfig 3 provides. You can run as many different PHP versions on the same server as you like, even with different compile options or whatever you want. You can easily select the PHP version that you want to use in the website settings, so when sita requires php 5.5 while site b requires php 7, then thats no problem at all as you can select the version for each website individually.

Share This Page