GD Modules

Discussion in 'General' started by MikeM, Sep 13, 2007.

  1. MikeM

    MikeM New Member

    I need to view some graphs on my site and it says I need gd modules. Does anybody know if this is supported with ISP Config and how I would install those modules?

    I'm kinda new with linux webhosting :rolleyes:

    Thanks.

    Mike Murphy
     
  2. Telesat

    Telesat ISPConfig Developer ISPConfig Developer

    It depends on your distribution

    It depends on your distribution, just install it using your packet manager.

    For deb based distros (Debian, Ubuntu...) I use aptitude:

    Code:
    aptitude update && aptitude search gd | grep ' GD '
    aptitude install libgd2-xpm libgdchart-gd2-xpm php4-gd php5-gd
    Note that you can install it for php4, php5 or both.

    For rpm based distros (Red Hat, Fedora, CentOS...) I use yum:

    Code:
    yum search gd
    yum install gd php-gd gd-progs
     
    Last edited: Sep 13, 2007
  3. MikeM

    MikeM New Member

    Yes, it is Debian 4

    Sorry I forgot to put that in. I set ISP Config up with Debian 4. I'll try the code you indicated.

    Thanks.

    Mike Murphy
     
  4. MikeM

    MikeM New Member

    Didn't seem to work.

    OK, I ran the indicated code, and it seemed to install, but I am still getting the error that I need to install gd modules. Any more ideas?

    Mike Murphy
     
  5. Telesat

    Telesat ISPConfig Developer ISPConfig Developer

    Which error, which web engine?

    Please post the error you get and the info about the web application that is trying to generate the graphs.
     
  6. MikeM

    MikeM New Member

    Got it

    Got it. I installed libgd-graph3d-perl and everything worked.

    Thanks for the help.
     

Share This Page