Gallery2 Permalinks (mod_rewrite) on ISPConfig with Multi-site installation

Discussion in 'Installation/Configuration' started by DantePasquale, Jan 28, 2009.

  1. DantePasquale

    DantePasquale Member HowtoForge Supporter

    Hi,

    I have Gallery2 running with latest stable ISPConfig on Ubuntu 8.10-64 AMD. Everything works fantastic. Except that I want to enable permalinks for many reasons.

    I downloaded and installed Gallery's Permalink plugin. The problem is that when I enable that plugin with any options checked, no web pages are found. But, if I clear all the options, save it, then things are back to normal.

    This creates a .htaccess in /var/www/web9/web/gallery directory. The codebase is in /var/www/web2/web.

    I'm not sure, but I think that with ISPConfig I need to add some sort of <Directory> directive in the Apache Directives Optional Screen for that web-site.

    Anyone else run into this? What solutions worked for you?

    Dante

    BTW, here's the .htaccess file generated by Gallery2 Permalinks Plugin:

    Code:
    # BEGIN Url Rewrite section
    # (Automatically generated.  Do not edit this section)
    <IfModule mod_rewrite.c>
        Options +FollowSymlinks
        RewriteEngine On
    
        RewriteBase /gallery/
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -d [OR]
        RewriteCond %{REQUEST_FILENAME} gallery\_remote2\.php
        RewriteCond %{REQUEST_URI} !/gallery/main\.php$
        RewriteRule .   -   [L]
    
        RewriteCond %{HTTP:Authorization} (.+)
        RewriteCond %{QUERY_STRING} !g2_authorization=
        RewriteRule .   %{REQUEST_URI}?g2_authorization=%1   [QSA]
        RewriteCond %{REQUEST_METHOD} OPTIONS
        RewriteRule .   http://gallery.cocoanet.us/modules/webdav/data/options/   [QSA,L]
        RewriteCond %{THE_REQUEST} /gallery/d/([0-9]+)-([0-9]+)/([^/?]+)(\?.|\ .)
        RewriteCond %{REQUEST_URI} !/gallery/main\.php$
        RewriteRule .   /gallery/main.php?g2_view=core.DownloadItem&g2_itemId=%1&g2_serialNumber=%2&g2_fileName=%3   [QSA,L]
        RewriteCond %{THE_REQUEST} /gallery/v/([^?]+)\.davmount(\?.|\ .)
        RewriteCond %{REQUEST_URI} !/gallery/main\.php$
        RewriteRule .   /gallery/main.php?g2_view=webdav.DownloadDavMount&g2_path=%1   [QSA,L]
        RewriteCond %{THE_REQUEST} /gallery/w(/[^?]*)?(\?.|\ .)
        RewriteCond %{REQUEST_URI} !/gallery/main\.php$
        RewriteRule .   /gallery/main.php?g2_controller=webdav.WebDav&g2_path=%1   [QSA,L]
        RewriteCond %{THE_REQUEST} /gallery/v/([^?]+)(\?.|\ .)
        RewriteCond %{REQUEST_URI} !/gallery/main\.php$
        RewriteRule .   /gallery/main.php?g2_path=%1   [QSA,L]
    </IfModule>
    
    # END Url Rewrite section
     
    Last edited: Jan 28, 2009
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    This rewrite code should work in a .htaccess file, no need to add it in the apache directives field. Is gallery2 installed directly in the "web" directory or in a subdirectory "web/gallery"? If its installed directly in the web directory, the line:

    RewriteBase /gallery/


    has to be:

    RewriteBase /
     
  3. DantePasquale

    DantePasquale Member HowtoForge Supporter

    Hi Till,

    Gallery is installed under web/gallery. Yeah, the re-write code looks fine, but it's not finding the pages when I have this file in place.

    It's actually a bit weirder than that. Let's say I open the main gallery, it opens fine, but none of the pictures are displayed. When I look at their URL's they are indeed rewritten.

    What's a good way to debug this?

    Thanks, Danté
     

Share This Page