gallerie and rewrite

Discussion in 'Installation/Configuration' started by fpl, Dec 4, 2005.

  1. fpl

    fpl New Member

    hello, and sorry for my bad english ;)

    I want install Gallerie software ( http://gallery.menalto.com )
    but i have some problem :
    1/
    Code:
    Warning!
    Apache is not obeying the 'php_value' lines in your .htaccess file. Try entering the following into your web server's httpd.conf file:
    <Directory /var/www/web6/web/pics>
    	AllowOverride Options FileInfo
    </Directory>
    If you are running PHP in CGI mode, this message is unavoidable.
    2/
    Code:
    Warning!
    Magic quotes are on. Your webserver administrator can turn them off by putting :
    	magic_quotes_gpc = Off
    in your php.ini file.
    3/
    Code:
    Warning!
    Either mod_rewrite is not installed or your .htaccess file is not enabled (see above). Either way, we'll have to use longer URLs in the Gallery. If you want to turn it on, first make sure that your .htaccess file is being obeyed. If it still doesn't work, you may need to reconfigure and rebuild Apache with this flag:
    	--enable-module=rewrite
    The gallery run, but not with rewrite url...

    I have try :
    1/ add the code in ' Directives Apache' of domain
    2/ modify On to Off in php.ini
    3/ i think is already enable?

    But, no url rewrite...

    Can you help me ?

    thanks
     
  2. falko

    falko Super Moderator

    Did you restart Apache afterwards?

    Do you see anything like
    Code:
    LoadModule [...]/mod_rewrite.so
    or similar in your httpd.conf?
    Which distribution do you use?
     
  3. fpl

    fpl New Member

    yes, restart Apache2 ... and ISPc

    my httpd.conf (apache2) :
    Code:
    # This is here for backwards compatability reasons and to support
    #  installing 3rd party modules directly via apxs2, rather than
    #  through the /etc/apache2/mods-{available,enabled} mechanism.
    #
    #LoadModule mod_placeholder /usr/lib/apache2/modules/mod_placeholder.so
    
    and my distrib is debian sarge ;)
    Just new debian with ispconfig.. I'm install with your tutoriel
     
  4. falko

    falko Super Moderator

    Try this:

    Code:
    cd /etc/apache2/mods-enabled
    ln -s /etc/apache2/mods-available/ssl.conf ssl.conf
    ln -s /etc/apache2/mods-available/ssl.load ssl.load
    ln -s /etc/apache2/mods-available/rewrite.load rewrite.load
    ln -s /etc/apache2/mods-available/suexec.load suexec.load
    ln -s /etc/apache2/mods-available/include.load include.load
    /etc/init.d/apache2 restart
     
  5. fpl

    fpl New Member

    hello falko,
    I have already this in /etc/apache2/mods-enabled :
    Code:
    lrwxrwxrwx  1 root root 36 2005-12-29 20:41 cgi.load -> /etc/apache2/mods-available/cgi.load
    lrwxrwxrwx  1 root root 40 2005-12-29 21:07 include.load -> /etc/apache2/mods-available/include.load
    lrwxrwxrwx  1 root root 37 2005-12-29 20:42 perl.conf -> /etc/apache2/mods-available/perl.conf
    lrwxrwxrwx  1 root root 37 2005-12-29 20:42 perl.load -> /etc/apache2/mods-available/perl.load
    lrwxrwxrwx  1 root root 37 2005-12-29 20:41 php4.conf -> /etc/apache2/mods-available/php4.conf
    lrwxrwxrwx  1 root root 37 2005-12-29 20:41 php4.load -> /etc/apache2/mods-available/php4.load
    lrwxrwxrwx  1 root root 40 2005-12-29 21:07 rewrite.load -> /etc/apache2/mods-available/rewrite.load
    lrwxrwxrwx  1 root root 36 2005-12-29 21:07 ssl.conf -> /etc/apache2/mods-available/ssl.conf
    lrwxrwxrwx  1 root root 36 2005-12-29 21:07 ssl.load -> /etc/apache2/mods-available/ssl.load
    lrwxrwxrwx  1 root root 39 2005-12-29 21:07 suexec.load -> /etc/apache2/mods-available/suexec.load
    lrwxrwxrwx  1 root root 40 2005-12-29 20:39 userdir.conf -> /etc/apache2/mods-available/userdir.conf
    lrwxrwxrwx  1 root root 40 2005-12-29 20:39 userdir.load -> /etc/apache2/mods-available/userdir.load
    I think it's good ?
    and :
    Code:
    more rewrite.load 
    LoadModule rewrite_module /usr/lib/apache2/modules/mod_rewrite.so
     
  6. falko

    falko Super Moderator

    ok, mod_rewrite is enabled so I think the .htaccess file of your gallery software isn't ok. Can you post it here?
     
  7. Mountainman

    Mountainman New Member

    Hi Falko,

    I'm currently confronted with the same probleme where gallery2 isn't able to detect the mod_rewrite.

    However when I do a http -l only the following modules show:
    Code:
    Compiled in modules:
      core.c
      mod_access.c
      mod_auth.c
      mod_log_config.c
      mod_logio.c
      mod_env.c
      mod_setenvif.c
      prefork.c
      http_core.c
      mod_mime.c
      mod_status.c
      mod_autoindex.c
      mod_negotiation.c
      mod_dir.c
      mod_alias.c
      mod_so.c
    
    and not the mod_rewrite :mad:

    How am I able to fix this?

    grz,
     
  8. sjau

    sjau Local Meanie

  9. falko

    falko Super Moderator

    Which distribution do you use?
     
  10. Mountainman

    Mountainman New Member

    I use Debian Sarge
     
  11. falko

    falko Super Moderator

    Try this:
    Code:
    a2enmod rewrite
    /etc/init.d/apache2 restart
     
  12. Mountainman

    Mountainman New Member

    It says:

    Code:
    This module is already enabled!
     
  13. falko

    falko Super Moderator

    Did you restart Apache?
     
  14. Mountainman

    Mountainman New Member

    Did apparantly fixed it... Weird eventhough :confused:

    But well it works :D

    tnx F!
     
  15. zitch

    zitch New Member

    I had some issues getting Gallery1 running on a site on a VPS running Debain Sarge (3.1) and ISPConfig (Wonderful tool there!) myself. I kept getting the "500 Error - Internal Server Error" everytime I tried to setup or access the gallery. Deleting the .htaccess file gets around this, but I'd rather keep as much functionality of the gallery avaliable as possible. I managed to get it working, and I'd figure it would be good to share for anybody else that's looking to get Gallery1 (and possibly other packages) running on their hosts.

    I managed to figure it out from this FAQ question.

    Basically, in ISPConfig, you want to enter something like the following in the Apache Directives (Optional): box of the site you want gallery in:

    Code:
    <Directory "/path/to/your/gallery/directory">
       AllowOverride Options FileInfo
    </Directory>
    For example, on my site, I have this:
    Code:
    <Directory '/var/www/web1/web/gallery'>
       AllowOverride Options FileInfo
    </Directory>
    Thanks, and I hope this helps others.
     
  16. TalkingToes

    TalkingToes New Member

    Gallery can use .htaccess

    Hi, and first post, so forgive my assumptions. I followed the Ubuntu 6.06 instructions for my installation of ISP Config. I have Gallery 1.5.4 .

    I did get around the .htaccess Yellow dot warning. Why does it work???

    Go to the http://localhost.local/gallery/setup/setup.php and note the two yellow dots. (about .htaccess and magic quotes).
    In the /setup/ directory, rename .htaccess to something
    Go to the http://localhost.local/gallery/setup/setup.php again, and they are gone, now green dots.
    Rename something back to .htaccess
    Go to the http://localhost.local/gallery/setup/setup.php again, it's still green. :)

    TalkingToes in Seattle, WA, USA
     
  17. Hans

    Hans Moderator

    How to for Gallery2

    Hi all,

    At this moment i am busy to write a How to for Gallery 2.
    (http://gallery.menalto.com/)

    Gallery comes with clear documentation, bu my Howto is specific for our ISPConfig server.

    I have installed it succesfully myself. Everything works great!
    I will post my Howto within 1 week.

    Within this how to, i will explain how to setup 1 core for different independent galleries on different domains. A multisite setup saves diskspace and administrative work.
     
    Last edited: Oct 8, 2006
  18. Hans

    Hans Moderator

    2 new howto's to setup Gallery2

    Today i've posted 2 new howto's for Gallery2 on an ISPConfig server:

    - The first howto descibes howto setup the Gallery2 codebase.
    - The second describes howto setup a multisite.

    During my own installation i made a lot of screendumps, because i wanted to make the howto's more clear. But i had to reduce them in size, with the result that the text within the pictures could not be read anymore. It was the reason for me not to post the pictures.

    Anyway, i hope that both howto's will be very helpful to setup Gallery2 on our ISPConfig server!

    :)

    More about Gallery2 can be found here: http://gallery.menalto.com/
     
    Last edited: Nov 16, 2006
  19. falko

    falko Super Moderator

    Great, I'll publish them soon! :)
     
  20. falko

    falko Super Moderator

Share This Page