Function Update OS not working

Discussion in 'General' started by bruno_floyd, Aug 28, 2012.

  1. bruno_floyd

    bruno_floyd New Member

    Hi everybody,

    After a while I'm coming back here to clarify another doubt of mine.

    I'm running ISPConfig3 Version 3.0.4.6 Multiserver setup on 7 Debian 6.0 servers (VM's), and trying to use the function update OS.

    I read that the update perform an "aptitude -y upgrade", and here I'm used to use "apt-get -y upgrade", I know it doesn't have any difference but I changed on the ISPconfig scripts the lines where it was written aptitude for apt-get.

    After changing that I went to the update OS function and selected All servers to do it. But only the master server and a database server were updated, and the others remains not updated.

    Does anyone has ever used that function with success?
    Am I missing some previous config to use it?

    Thanks guys! ;D
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    It does the same, so no need to change anything in the code.

    Yes, works fine on my servers.

    If you want to debug server actions on your slave servers, check out the debug instructions in the faq.
     
  3. bruno_floyd

    bruno_floyd New Member


    Thanks for the reply till!

    I followed the FAQ instructions and I did the following:
    I ran the update function on the interface, disabled the cron, and ran the command, which gave me:

    sh: repquota: not found
    sh: repquota: not found
    /usr/bin/fail2ban-client
    /sbin/iptables
    /sbin/ip6tables
    finished.

    Is there any relationship with the updates?

    Thanks again!
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    No, thats not related to the updates.

    Did you disable the cronjob first, then clicked on the update in ispconfig again before you run the script? If you presed the update button first and then disabled cron, the output can be incorrect.
     
  5. bruno_floyd

    bruno_floyd New Member

    That's correct till... I did that way.
    First disabled and then ran the update.
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Ok. Other changes get transferred correctly to that server? E.g. when you modify a website, dns record or mailbox depending on what the server is used for?
     
  7. bruno_floyd

    bruno_floyd New Member

    Yes till... everything is running beautifully!
    I have 2 Webservers, 2 DNS Servers, 2 Mail Servers and 1 DB Server.

    Just for the record, I just changed the aptitude for apt-get because the update function wasn't working, so I tried this.

    :D
     
  8. bruno_floyd

    bruno_floyd New Member

    Do you have any other clue till?

    Thanks for the support!
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    And all servers, master and slaves use ISPConfig 3.0.4.6?
     
  10. bruno_floyd

    bruno_floyd New Member

    Yes, all at the 3.0.4.6 version.
     

Share This Page