FTPS error

Discussion in 'Server Operation' started by misterm, Dec 11, 2007.

  1. misterm

    misterm Member HowtoForge Supporter

    Hello with do all, I have to test the howto of Falko on the ftp, in SSL, is when I try to connect me with my waiter, it does not find the certificate, I use my waiter, with ispconfig, which is the error?

    http://www.howtoforge.com/proftpd-tls-debian-etch

    MM:eek:
     
  2. falko

    falko Super Moderator Howtoforge Staff HowtoForge Supporter

    Any errors in your logs?
     
  3. misterm

    misterm Member HowtoForge Supporter

    Hello falko, here errors that it me but...


    MM:confused:
     
  4. falko

    falko Super Moderator Howtoforge Staff HowtoForge Supporter

    Are you sure you followed the tutorial as close as possible?
     
  5. misterm

    misterm Member HowtoForge Supporter

    Falko, maitre Falko, King de ISPConfig, without laughing, I also did what you said to me with your howto, I made all lines, is I always have the same error...

    Exact configuration of the howto :

    Is here what it me but when I use FileZilla, you notice that I have to withdraw my address IP...., but I have even this error when I use FileZilla...

    MM;) :rolleyes:
     
  6. falko

    falko Super Moderator Howtoforge Staff HowtoForge Supporter

    Do you use FTPES in FileZilla instead of normal FTP?
     
  7. misterm

    misterm Member HowtoForge Supporter

    Falko, this image gives the essential proof of what I say, falko, it with you it a different problem leaves there, does not forget that I am at ovh, is it uses a technology IPV4 or place of IPV6, perhaps that it is that, says to me what, thank you....

    http://www.michelrenard.be/images/fileZillaSSL.jpg

    ;)
     
  8. misterm

    misterm Member HowtoForge Supporter

    /usr/sbin/proftpd -l no the mod_tls indicated

    Falko, it is possible that the version of Proftpd de Debian Etch, is not was to compile with the function mod_tls, I raise the question, because, when I carry out this order, it of it is nothing, possible Falko...

    MM :rolleyes:
     
  9. falko

    falko Super Moderator Howtoforge Staff HowtoForge Supporter

    Did you enable TLs in /etc/proftpd/proftpd.conf?
     
  10. misterm

    misterm Member HowtoForge Supporter

    Falko, yes it activates in proftpd.conf, at home that functions with integrated ISPConfig, you have "mod_tls" active when you carries out this command "/usr/sbin/proftpd -/L", tries my to include/understand, I have read again your howto, is I did exactly what me ace say, I cannot be more correct than that or is it with a different problem leaves there...., all is the question that I pose to you... :eek:
     
  11. jupiter2005ster

    jupiter2005ster New Member

    :(

    Hello!
    I'm Hungarian and I learning english now so please you forgive language mistakes. :)
    I everything do it than you wrote in topic: http://www.howtoforge.com/proftpd-tls-debian-etch only but I use gproftpd.
    I configure proftpd.conf with gproftpd thus:
    ServerType standalone
    DefaultServer on
    Umask 022
    ServerName "0.0.0.0"
    ServerIdent on "My FTPD"
    ServerAdmin Admin@this.domain.topdomain
    IdentLookups off
    UseReverseDNS off
    Port 21
    PassivePorts 49152 65534
    #MasqueradeAddress None
    TimesGMT off
    MaxInstances 30
    MaxLoginAttempts 3
    TimeoutLogin 300
    TimeoutNoTransfer 120
    TimeoutIdle 120
    DisplayLogin welcome.msg
    DisplayFirstChdir .message
    User nobody
    Group nobody
    DirFakeUser off nobody
    DirFakeGroup off nobody
    DefaultTransferMode binary
    AllowForeignAddress on
    AllowRetrieveRestart on
    AllowStoreRestart on
    DeleteAbortedStores off
    TransferRate RETR 80000
    TransferRate STOR 80000
    TransferRate STOU 80000
    TransferRate APPE 80000
    SystemLog /var/log/secure
    RequireValidShell off
    #gp_random_username_length 6
    #gp_random_password_length 6
    #gp_randomize_case lower
    #gp_useradd_homedir_path /var/ftp
    #gp_useradd_upload_path /upload
    #gp_html_path /var/www/html/ftp.htm
    #gp_welcome_name welcome.msg
    <IfModule mod_tls.c>
    TLSEngine on
    TLSLog /var/log/proftpd/tls.log
    TLSProtocol SSLv23
    TLSOptions NoCertRequest
    TLSRSACertificateFile /etc/proftpd/ssl/proftpd.cert.pem
    TLSRSACertificateKeyFile /etc/proftpd/ssl/proftpd.key.pem
    TLSVerifyClient off
    TLSRequired on
    </IfModule>

    and doesn't work sftp. In TC(totalcommander) and UltraFXP didn't open SSL contact. It wrote: 500 AUTH not understood
    but the Debian,OpenSSL and Proftpd don't wirte error.
     
  12. misterm

    misterm Member HowtoForge Supporter

    Find a solution, for this problem

    Hello, me also, I have evil to express myself in English, but I had the same problem, I hope that falko is till, go find a solution, for this problem...

    :confused: ;)

    MM
     
  13. falko

    falko Super Moderator Howtoforge Staff HowtoForge Supporter

    Any errors in your logs?
     
  14. jupiter2005ster

    jupiter2005ster New Member

    In logs are some problem with IPV6 because I didn't set off, but I haven't need IPV6 yet. I don't understand that why it haven't gone.
    Do you it run Falco?
     
  15. falko

    falko Super Moderator Howtoforge Staff HowtoForge Supporter

    Change UseIPv6 from on to off in your proftpd.conf and restart ProFTPd.
     
  16. jupiter2005ster

    jupiter2005ster New Member

    Thanks Falko, I did it, but unfortunately it does not solve the problem. It still hasn't understood AUTH SSL. Do you have any other idea?
     
  17. daveb

    daveb Member

  18. jupiter2005ster

    jupiter2005ster New Member

    Thanks, but it didn't help "AUTH not understood".
     
  19. falko

    falko Super Moderator Howtoforge Staff HowtoForge Supporter

    Can you post your full proftpd.conf?
     
  20. SupuS

    SupuS Member HowtoForge Supporter

    Hi Falco

    I have same problem with my ispconfig on Ubuntu box. In my proftpd.conf is:

    Code:
    #
    # /etc/proftpd/proftpd.conf -- This is a basic ProFTPD configuration file.
    # To really apply changes reload proftpd after modifications.
    #
    
    # Includes DSO modules
    Include /etc/proftpd/modules.conf
    
    # Set off to disable IPv6 support which is annoying on IPv4 only boxes.
    UseIPv6                         off
    
    ServerName                      "Name of Server"
    ServerType                      standalone
    DeferWelcome                    off
    
    MultilineRFC2228                on
    DefaultServer                   on
    ShowSymlinks                    on
    
    TimeoutNoTransfer               600
    TimeoutStalled                  600
    TimeoutIdle                     1200
    
    DisplayLogin                    welcome.msg
    DisplayFirstChdir               .message
    ListOptions                     "-l"
    
    DenyFilter                      \*.*/
    
    # Use this to jail all users in their homes
    DefaultRoot                     ~
    IdentLookups off
    ServerIdent on "FTP Server ready."
    
    # Users require a valid shell listed in /etc/shells to login.
    # Use this directive to release that constrain.
    # RequireValidShell             off
    
    # Port 21 is the standard FTP port.
    Port                            21
    
    # In some cases you have to specify passive ports range to by-pass
    # firewall limitations. Ephemeral ports can be used for that, but
    # feel free to use a more narrow range.
    # PassivePorts                  49152 65534
    
    # If your host was NATted, this option is useful in order to
    # allow passive tranfers to work. You have to use your public
    # address and opening the passive ports used on your firewall as well.
    # MasqueradeAddress             1.2.3.4
    
    # To prevent DoS attacks, set the maximum number of child processes
    # to 30.  If you need to allow more than 30 concurrent connections
    # at once, simply increase this value.  Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd)
    MaxInstances                    30
    
    # Set the user and group that the server normally runs at.
    User                            proftpd
    Group                           nogroup
    
    # Umask 022 is a good standard umask to prevent new files and dirs
    # (second parm) from being group and world writable.
    Umask                           022  022
    # Normally, we want files to be overwriteable.
    AllowOverwrite                  on
    
    # Uncomment this if you are using NIS or LDAP to retrieve passwords:
    # PersistentPasswd              off
    
    # Be warned: use of this directive impacts CPU average load!
    # Uncomment this if you like to see progress and transfer rate with ftpwho
    # in downloads. That is not needed for uploads rates.
    #
    # UseSendFile                   off
    
    # Choose a SQL backend among MySQL or PostgreSQL.
    # Both modules are loaded in default configuration, so you have to specify the backend
    # or comment out the unused module in /etc/proftpd/modules.conf.
    # Use 'mysql' or 'postgres' as possible values.
    #
    #<IfModule mod_sql.c>
    # SQLBackend                    mysql
    #</IfModule>
    
    TransferLog /var/log/proftpd/xferlog
    SystemLog   /var/log/proftpd/proftpd.log
    
    #<IfModule mod_tls.c>
    #TLSEngine off
    #</IfModule>
    
    # TLS http://www.howtoforge.com/forums/showthread.php?t=7987&highlight=ssl
    #<IfModule mod_tls.c>
    # TLSEngine on
    # TLSLog /var/log/proftpd/proftpd_tls.log
    # TLSProtocol TLSv1
    # TLSRequired off
    # TLSVerifyClient off
    # TLSRSACertificateFile /etc/ssl_proftp/host.cert
    # TLSRSACertificateKeyFile /etc/ssl_proftp/host.key
    #</IfModule>
    
    <IfModule mod_tls.c>
    TLSEngine                  on
    TLSLog                     /var/log/proftpd/tls.log
    TLSProtocol                SSLv23
    TLSOptions                 NoCertRequest
    TLSRSACertificateFile      /etc/proftpd/ssl/proftpd.cert.pem
    TLSRSACertificateKeyFile   /etc/proftpd/ssl/proftpd.key.pem
    TLSVerifyClient            off
    TLSRequired                on
    </IfModule>
    
    <IfModule mod_quota.c>
    QuotaEngine on
    </IfModule>
    
    <IfModule mod_ratio.c>
    Ratios on
    </IfModule>
    
    
    # Delay engine reduces impact of the so-called Timing Attack described in
    # http://security.lss.hr/index.php?page=details&ID=LSS-2004-10-02
    # It is on by default.
    <IfModule mod_delay.c>
    DelayEngine on
    </IfModule>
    
    <IfModule mod_ctrls.c>
    ControlsEngine        on
    ControlsMaxClients    2
    ControlsLog           /var/log/proftpd/controls.log
    ControlsInterval      5
    ControlsSocket        /var/run/proftpd/proftpd.sock
    </IfModule>
    
    <IfModule mod_ctrls_admin.c>
    AdminControlsEngine on
    </IfModule>
    
    # A basic anonymous configuration, no upload directories.
    
    # <Anonymous ~ftp>
    #   User                                ftp
    #   Group                               nogroup
    #   # We want clients to be able to login with "anonymous" as well as "ftp"
    #   UserAlias                   anonymous ftp
    #   # Cosmetic changes, all files belongs to ftp user
    #   DirFakeUser on ftp
    #   DirFakeGroup on ftp
    #
    #   RequireValidShell           off
    #
    #   # Limit the maximum number of anonymous logins
    #   MaxClients                  10
    #
    #   # We want 'welcome.msg' displayed at login, and '.message' displayed
    #   # in each newly chdired directory.
    #   DisplayLogin                        welcome.msg
    #   DisplayFirstChdir           .message
    #
    #   # Limit WRITE everywhere in the anonymous chroot
    #   <Directory *>
    #     <Limit WRITE>
    #       DenyAll
    #     </Limit>
    #   </Directory>
    #
    #   # Uncomment this if you're brave.
    #   # <Directory incoming>
    #   #   # Umask 022 is a good standard umask to prevent new files and dirs
    #   #   # (second parm) from being group and world writable.
    #   #   Umask                           022  022
    #   #            <Limit READ WRITE>
    #   #            DenyAll
    #   #            </Limit>
    #   #            <Limit STOR>
    #   #            AllowAll
    #   #            </Limit>
    #   # </Directory>
    #
    # </Anonymous>
    
    Include /etc/proftpd_ispconfig.conf
    mod_tls is listed in compiled in modules:

    Code:
    # ftpdctl lsmod
    ftpdctl: Loaded Modules:
    ftpdctl:   mod_core.c
    ftpdctl:   mod_xfer.c
    ftpdctl:   mod_auth_unix.c
    ftpdctl:   mod_auth_file.c
    ftpdctl:   mod_auth.c
    ftpdctl:   mod_ls.c
    ftpdctl:   mod_log.c
    ftpdctl:   mod_site.c
    ftpdctl:   mod_delay.c
    ftpdctl:   mod_dso.c
    ftpdctl:   mod_auth_pam.c
    ftpdctl:   mod_readme.c
    ftpdctl:   mod_cap.c
    ftpdctl:   mod_ctrls.c
    ftpdctl:   mod_ctrls_admin.c
    ftpdctl:   mod_tls.c
    ftpdctl:   mod_sql.c
    ftpdctl:   mod_ldap.c
    ftpdctl:   mod_sql_mysql.c
    ftpdctl:   mod_sql_postgres.c
    ftpdctl:   mod_quotatab.c
    ftpdctl:   mod_quotatab_file.c
    ftpdctl:   mod_quotatab_ldap.c
    ftpdctl:   mod_quotatab_sql.c
    ftpdctl:   mod_radius.c
    ftpdctl:   mod_wrap.c
    ftpdctl:   mod_rewrite.c
    ftpdctl:   mod_ifsession.c
    In /var/log/proftpd/tls.log is only:

    Code:
    Mar 11 15:42:40 mod_tls/2.1.1[22570]: using default OpenSSL verification locations (see $SSL_CERT_DIR environment variable)
    Mar 11 15:43:37 mod_tls/2.1.1[22654]: using default OpenSSL verification locations (see $SSL_CERT_DIR environment variable)
    Mar 11 15:44:40 mod_tls/2.1.1[22677]: using default OpenSSL verification locations (see $SSL_CERT_DIR environment variable)
    Mar 11 15:45:37 mod_tls/2.1.1[22734]: using default OpenSSL verification locations (see $SSL_CERT_DIR environment variable)
    As you can see I tried two ways of configuration by your howto and howto by Tom - http://www.howtoforge.com/forums/showthread.php?t=7987&highlight=ssl (commented lines with TLS mode enabled) but without success.

    I have another server with Ubuntu and proftpd configured as described in Tom's howto without ispconfig and it goes fine.

    thanks for any suggestions.

    SupuS
     

Share This Page