ftplicity problems

Discussion in 'Server Operation' started by Ovidiu, Dec 11, 2006.

  1. Ovidiu

    Ovidiu Active Member

    hi there,

    I am trying to restore a BIG folder with all its content like this:



    can anyone help me with this error messages? it simply stops restoring so I will try and restore each subfolder and file separately in the meantime but I have to sort this out urgently...

    please give some advice.
     
  2. falko

    falko Super Moderator

  3. Ovidiu

    Ovidiu Active Member

    thx for digging that up for me, still some posts are old, no one had any reply, and her I am again :-( using an autoamted backup system that is no good and worked so fien in the beginning, being even recommended by a serious german magazice (ct)...

    well I think it is time to look for another one....
    as this oen is no good, I could just not restore a very big folder, had to manually restore a lot of files ...
     
  4. Ovidiu

    Ovidiu Active Member

    can anyone point me to a clean, working solution to backup a serevr? something like daily, weekly, monthly backup, differential, maybe incremental even...

    I have a root server from strato and they provide access to a ftp partition the same size my server has...

    I have been using ftplicity until now but lately I get backend errors all over the place...
     
  5. falko

    falko Super Moderator

  6. Ovidiu

    Ovidiu Active Member

    well, both articles you linked seem to be needing two full accessible servers, but strato only offers a backupserver with ftp access, thats it, no install, no ssh, nothing except for ftp access...

    any other ideas?
     
  7. falko

    falko Super Moderator

    To be honest, I wouldn't store my backups on a server that is not entirely under my control. What if there are passwords or other sensitive data in the backups?
     
  8. Ovidiu

    Ovidiu Active Member

  9. Ovidiu

    Ovidiu Active Member

    I think this is not just a small ftplicity error as I tried deleting old backups and it tells me the newer ones depend on them, so it seems the full backup is not fully performed. I told ftplicity to store backups for 1 months:

    so this shows me having 3 months of backups, I guess because the full backup does not run? I tried running it manually and got:

    unfortunately I still can't find help on the net.
    any ideqas what to do? the system was wonderful as long as it worked, now I need to fix it or change it.
     
  10. Ovidiu

    Ovidiu Active Member

    can someone who understands german pm me so I can pm you the link to the other forum? I have posted in another german-speaking forum and those posts might help solve this problems
     
  11. Ovidiu

    Ovidiu Active Member

    I started a backup again, with verbosity=9 and here is the last valid output:

    thats how it ends - any ideas or suggestions?
     
  12. Ovidiu

    Ovidiu Active Member

    ok guys,

    any hints for me? where to look for help. I would pay to solve this as I need my backup system running again.

    Is it a ftplicity problem? Or a duplicity or gnupg or ncftp problem? Or is the problem with the ftp server? Or is a certain file to blame?

    I have no clue, I jsut know the backup process stops like yo ucan see in the above logfile....
     
  13. falko

    falko Super Moderator

    I have no idea (otherwise I'd have replied...). :(
     
  14. Ovidiu

    Ovidiu Active Member

    THX.

    This will mark this as a dead end :-(
     
  15. Ovidiu

    Ovidiu Active Member

    another hint from the duplicity page:

    could this be a problem? I have not done anything with hardlinks so far, I am going to read on the net about them... find out how I can spot them and see if there are any inside the dirs I backup.
     
  16. martinfst

    martinfst HowtoForge Supporter

    Hard links are identified by having the same inode number.
    Code:
    ls -i
    will show files with their i-node number. I don't recall a single command to find hardlinked files. I would write a some script to traverse the directory tree, sort it on i node and see if there are matches. Hardlinks only exist per filesystem, so that limits where to search. HTH.
     
  17. Ovidiu

    Ovidiu Active Member

    the hardlinks don't seem to be the problem, thx for the suggestion anyway.. :-(
     
  18. Ovidiu

    Ovidiu Active Member

    it seems there are news on this topic:

    I found another of my threads here: http://www.howtoforge.com/forums/showthread.php?t=6213&highlight=ftplicity

    also a nice thread with a patch: http://serversupportforum.de/forum/...lem-mit-duplicity-ftplicity-3.html#post104368
    the last poster is also called falko, might be this falko?

    also some other modified duplicities and ftplicity scripts:
    http://www.weareroot.de/2007/08/17/ftplicity-inkrementelle-backups-sicher-ablegen/
    http://www.weareroot.de/2007/12/02/duplicity-046-released/


    I am still testing all this new input, just posted here for other users.
     
  19. falko

    falko Super Moderator

  20. Ovidiu

    Ovidiu Active Member

    yes I have found your tutorial, still, my problems changed from the "broken Pipe problem" which was solved by a patch in one of the threads I linked to here, to this one:

    FYI I have manually compiled duplicity version 0.4.6 as the current version in debian stable seems to be 0.4.2 if I am not mistaken. The links I listed showed problems solved in versions > 0.4.4 and recommend using those.

    Do you have any clue about the current errors I posted in this postß
     

Share This Page