ftp_logs.php kill proftpd server

Discussion in 'General' started by SupuS, Dec 16, 2009.

  1. SupuS

    SupuS Member HowtoForge Supporter

    Hi all

    I have new install of Ubuntu Karmic 9.10 installed with using the perfect setup. Proftpd server is killed every night by ftp_logs.php.

    Code:
    Dec 15 23:59:01 www.example.com proftpd[12172] www.example.com: ProFTPD killed (signal 15)
    Dec 15 23:59:01 www.example.com proftpd[12172] www.example.com: ProFTPD 1.3.2 standalone mode SHUTDOWN
    
    When I run cron command I get:

    Code:
    # /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php
    grep: /var/log/xferlog.0: No such file or directory
    
    and proftpd goes down.

    Code:
    # ls -l /var/log/ |grep xferlog
    -rw-r--r-- 1 root      root          0 Dec 13 01:39 xferlog
    
    Code:
    # ls -l /var/log/proftpd/ |grep xferlog
    -rw-r----- 1 root adm  248626 Dec 16 10:27 xferlog
    -rw-r--r-- 1 root root    833 Dec 13 18:55 xferlog.1
    
    Globally I have only one log file with 0 suffix:

    Code:
    # find /var/log -name "*.0"
    /var/log/dmesg.0
    
    and a lot of files with suffix 1 and higher:

    Code:
    # find /var/log -name "*.1"
    /var/log/proftpd/xferlog.1
    /var/log/proftpd/proftpd.log.1
    /var/log/mail.info.1
    /var/log/kern.log.1
    /var/log/mail.err.1
    /var/log/debug.1
    /var/log/auth.log.1
    /var/log/clamav/clamav.log.1
    /var/log/clamav/freshclam.log.1
    /var/log/apache2/access.log.1
    /var/log/apache2/error.log.1
    /var/log/apache2/other_vhosts_access.log.1
    /var/log/mail.log.1
    /var/log/daemon.log.1
    /var/log/messages.1
    /var/log/syslog.1
    /var/log/mail.warn.1
    /var/log/user.log.1
    
    Where can I set file names which are checked by ftp_logs.php? Or is it better to set suffix in proftp logrotate config file by start directive?

    Thanks

    SupuS
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess you will ahve to edit it directly in ftp_logs.php. Please add a bugreport in the bugtracker so we can check this for the next release.
     
  3. SupuS

    SupuS Member HowtoForge Supporter

    I added task to bugtracker. Thanks.

    SupuS
     
  4. savago

    savago New Member

    I confirm that.this bug is working still now in 2.2.36
     
  5. falko

    falko Super Moderator ISPConfig Developer

    I've just fixed it.
     
  6. savago

    savago New Member

    And how we can fix/patch this ?
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Till will release ISPConfig 2.2.37 today. Just update your ISPConfig.
     

Share This Page