Ftp

Discussion in 'Server Operation' started by Breezer, Jan 28, 2011.

  1. Breezer

    Breezer New Member

    Hello, i am new in linux world, but i have followed the The Perfect Server - CentOS 5.5 x86_64 [ISPConfig 3], it seemed to me that everything installed fine, i followed the suggestions that were made even if the install wasn't working from the comments bellow... anyways I have an issue the the pureftpd and ispconfig 3.... using FileZilla, i am able to log in as root onto the server with ftp.... the minute i care a user on the ispconfig 3 for ftp... it does not work... it keeps saying authentication failed....

    my though is that the directorys do not match for the username and passwords with pureftp/myphpadmin/ispconfig, am I on the right track? or way off please help

    Thank you
     
  2. pititis

    pititis Member

    root login is not allowed. Check /etc/ftpusers
     
  3. Breezer

    Breezer New Member

    Sorry that directory does not exist...

    the thing is i have tried logging in as root and it did work...

    I can not create users in ISPConfig 3, they do not authenticate...
     
    Last edited: Jan 28, 2011
  4. falko

    falko Super Moderator

    Did you try both active and passive transfers in your FTP client?
    Is SELinux disabled?
    Is this a physical server or a virtual machine?
     
  5. Breezer

    Breezer New Member

    Did you try both active and passive transfers in your FTP client?

    --> yes i have tried both (its give me authentication error)

    Is SELinux disabled?

    --> yes it is disabled

    Is this a physical server or a virtual machine?

    It is a physical server...


    to me it seems like the ISPconfig 3 and the pureftd are looking a different directory for username and password....

    I am not sure how to check if the are looking at the same files... Thanks
     
  6. falko

    falko Super Moderator

    Do you have any error messages that you can post, e.g. from your FTP client and your server logs?
     
  7. Breezer

    Breezer New Member

    sure thing....
    this happens when i log in a root with ftp filezilla:

    Status: Connecting to 555.555.555.555...
    Response: fzSftp started
    Command: open "root@555.555.555.555" 22
    Command: Pass: ********
    Status: Connected to 555.555.555.555
    Status: Retrieving directory listing...
    Command: pwd
    Response: Current directory is: "/root"
    Status: Directory listing successful

    NOW!!!!

    when creating a user in ISPConfig3 --- trying to connect with a user by just changing user name and password--->

    Status: Connecting to 555.555.555.555...
    Response: fzSftp started
    Command: open "user1@555.555.555.555" 22
    Command: Pass: ********
    Error: Authentication failed.
    Error: Critical error
    Error: Could not connect to server


    when I check out show system log in ISPConfig 3 i get
    Feb 2 14:20:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Feb 2 14:20:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.

    every 5 min
     
  8. falko

    falko Super Moderator

    Did you mark that FTP account as active in ISPConfig?
    Any errors in your auth log?
     
  9. Breezer

    Breezer New Member

    Yes it is Active... its checked as default
    Where would i find Authentication log file?

    in ispconfig3 under monitor Logfiles this is what i find...
    * Show Mail Queue
    * Show Mail Log
    * Show Mail Warn-Log
    * Show Mail Error-Log
    * Show System-Log
    * Show ISPC Cron-Log
    * Show Freshclam-Log
    * Show Clamav-Log
    * Show RKHunter-Log
    * Show fail2ban-Log

    no Auth log

    please let me know how i can check the auth log thanx and ill let you know what it says....

    Thank You
     
  10. falko

    falko Super Moderator

    The auth log should be located in /var/log/.
     
  11. Breezer

    Breezer New Member

    I have checked pureftpd.log file and it was nothing there.... and these are all the log files under that directory.... and no authentication log.... should i look at any other log files?

    acpid / ispconfig / rpmpkgs.1
    anaconda.log / ispconfig_install.log / rpmpkgs.2
    anaconda.syslog / lastlog / rpmpkgs.3
    anaconda.xlog / mail / samba
    audit / maillog / scrollkeeper.log
    boot.log / maillog.1 / secure
    boot.log.1 / maillog.2 / secure.1
    boot.log.2 / maillog.3 / secure.2
    boot.log.3 / mcelog / secure.3
    btmp / messages / setroubleshoot
    clamav / messages.1 / spooler
    conman / messages.2 / spooler.1
    conman.old / messages.3 / spooler.2
    cron / mysqld.log / spooler.3
    cron.1 / pm / squid
    cron.2 / ppp / tallylog
    cron.3 / prelink wtmp
    cups / pureftpd.log / Xorg.setup.log
    dmesg / rkhunter.log / yum.log
    fail2ban.log / rkhunter.log.old / yum.log.1
    faillog / rpmpkgs
    httpd
     
  12. falko

    falko Super Moderator

    Please check /var/log/messages for authentication errors.
     
  13. gummiv

    gummiv New Member

    Hey there,

    I´m having the exact same problem as Breezer here.

    I have created an ftp user under a client and that user is marked as active. When I try to connect via filezilla, I get the same error messages as posted earlier in this thread. I can however connect as root, even though root is present in ftpusers under /etc

    Here is what pops up in the auth.log:

    sshd[18060]: Invalid user **** from 192.168.255.3
    sshd[18060]: Failed none for invalid user **** from 192.168.255.3 port 53982 ssh2
    sshd[18060]: pam_unix(sshd:auth): check pass; user unknown
    sshd[18060]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=192.168.255.3

    So obviously the ftp does not recognize the user I created in ISPConfig, so the question is why not?
     
  14. Breezer

    Breezer New Member

    I have checked there there is no authentication log... but there was pureftpd.log i have checked it out and there is nothing there...
     
  15. falko

    falko Super Moderator

    Did you check /var/log/messages?
     
  16. falko

    falko Super Moderator

    Please open a new thread.
     
  17. Breezer

    Breezer New Member

    yes i did this is what it was showing when i was trying to log in with the user that i created through ispconfig 3

    Feb 9 09:30:02 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Feb 9 09:30:02 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
    Feb 9 09:30:59 server1 ntpd[4533]: time reset -0.467956 s
    Feb 9 09:31:42 server1 clamd[4546]: SelfCheck: Database status OK.
    Feb 9 09:34:27 server1 ntpd[4533]: synchronized to LOCAL(0), stratum 10
    Feb 9 09:35:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Feb 9 09:35:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
    Feb 9 09:36:37 server1 ntpd[4533]: synchronized to 216.194.70.2, stratum 2
    Feb 9 09:40:02 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Feb 9 09:40:02 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
    Feb 9 09:41:42 server1 clamd[4546]: SelfCheck: Database status OK.
    Feb 9 09:45:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Feb 9 09:45:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
    Feb 9 09:50:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Feb 9 09:50:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
    Feb 9 09:51:42 server1 clamd[4546]: SelfCheck: Database status OK.
    Feb 9 09:55:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Feb 9 09:55:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
    Feb 9 10:00:02 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Feb 9 10:00:02 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
    Feb 9 10:01:42 server1 clamd[4546]: SelfCheck: Database status OK.
    Feb 9 10:05:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Feb 9 10:05:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
    Feb 9 10:10:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Feb 9 10:10:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
    Feb 9 10:11:42 server1 clamd[4546]: SelfCheck: Database status OK.
    Feb 9 10:15:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Feb 9 10:15:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
    Feb 9 10:20:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Feb 9 10:20:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.


    this happens all the time even if i do not try to log in....
     
  18. Breezer

    Breezer New Member

    I've been doing little bit of research... and i have came across this

    Then, you have to run the pure-ftpd command with '-l mysql:' (it's an 'ell'
    not a 'one') followed by the path of that configuration file. Here's an
    example with tcpserver:

    tcpserver -DHRl0 0 21 /usr/local/bin/pure-ftpd -l mysql:/etc/pureftpd-mysql.conf &

    You can mix different authentication methods. For instance, if you want to
    use system (/etc/passwd) accounts when an account is not found in a MySQL
    database, use -l mysql:/etc/pureftpd-mysql.conf -l unix


    now is it possible that ftp is not pointed into the appropriate directory, as in its only pointed to mysql and not etc/passwd so thats why i can only log in with my root sql password... ?

    if so how can i fix this so its pointed to both directories.... if NOT disregard this thought...
     
  19. lightning200mph

    lightning200mph New Member

    This may have already been said but I didn't read all the post completely.
    Your user name you are log in in with might be the problem, I also had this problem until I figured it out. So when you create a client lets say "Website1" then next step is the FTP-user "ftp1" under websites. So the log in name should be "website1ftp1" for the log in to work.

    You will see [clientname]"username" on the ftp user name screen. So I put them together and it worked for me

    Zach
     
  20. Breezer

    Breezer New Member

    No that is not the issue... I have already tried that and made sure that i am using the full name ie website1ftp1, and the right password... also tried the different transfer settings : default / active / passive and none of them work.
    I get the same response all the time

    Response: fzSftp started
    Command: open "website1ftp1@555.555.555.555" 22
    Command: Pass: ********
    Error: Authentication failed.
    Error: Critical error
    Error: Could not connect to server

    thats why it makes me think that the pureftpd is not looking at the same folder that the the ispconfig creates the usernames and passwords for ftp.
     

Share This Page