FTP won't connect (227 Entering Passive Mode)

Discussion in 'Server Operation' started by Manisch, Dec 21, 2020.

  1. Manisch

    Manisch New Member HowtoForge Supporter

    Hi there,

    I have some trouble with my FTP connection.
    Already tried this short tutorial:
    "How to set PassivePortRange and PassiveIP in pure-ftpd on Debian and Ubuntu Linux"
    (Can't post a link since I'm new)

    But it still won't connect and says:
    Status: Connection established, waiting for welcome message...
    Status: Initializing TLS...
    Status: Verifying certificate...
    Status: TLS connection established.
    Status: Logged in
    Status: Retrieving directory listing...
    Command: PWD
    Response: 257 "/" is your current location
    Command: TYPE I
    Response: 200 TYPE is now 8-bit binary
    Command: PASV
    Response: 227 Entering Passive Mode (1,2,3,4,156,219)
    Command: MLSD
    Error: Connection timed out after 20 seconds of inactivity
    Error: Failed to retrieve directory listing

    I'm quite new to all this, so please keep it simple :D

    Edit: Could one issue be that I'm using ProFTPD and not pure-ftpd, so the tutorial won't help anyways? :D
    Turning the Firewall off doesn't change that much...
     
    Last edited: Dec 21, 2020
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Is this on an ISPConfig host? If you follow the Perfect Server Guide to install and setup the system, then it works. If you do not follow the instructions, then it does not work.
    Did you set up the passive port range in the FTP software you eventually use? Did you open the same ports in all firewalls between that host and client trying to connect with FTP?
     
  3. Manisch

    Manisch New Member HowtoForge Supporter

    Yes, I did. Well, at least I thought so. I even did it 2-3 times, just because I felt there was a minor error :D

    I'm using Filezilla.
    The Connection had the setting "default" at first, now I changed it to passive, which doesn't seem to change anything.

    When I search for Passive Port Range, I find some tutorials for Filezilla Server, does that mean, I can't use the regular version?

    And how do I find out all the ports/firewalls I have to check?
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    You choose a range of ports to use for your passive ftp connections. Then configure your ftp server to use those. Then open those same ports in every firewall you have (host level and network level firewalls). If you use NAT for your server's address you will also need to forward those ports in your NAT router.
     
  5. Manisch

    Manisch New Member HowtoForge Supporter

    Well, to be honest: This sounds a little too "complex" to me :D
    Or more like: The error must be somewhere else.

    I tried installing ISPConfig a different way (Ubuntu instead of Debian), and now it works.
     

Share This Page