FTP : what a pity ... ;-)

Discussion in 'Installation/Configuration' started by ledufakademy, Aug 24, 2020.

  1. ledufakademy

    ledufakademy Member

    i follow all tuto for web server conf. but it's impossible to connect to this f... pure-ftp server ... !!!

    firewall is open on server and upstream firewall (nat etc) , tcp 21

    command ftp -p ftp.domain.com
    [...]
    Password:
    230 OK. Current restricted directory is /
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp> ls
    227 Entering Passive Mode (89,234,140,99,156,214)
    ftp: connect: Connection timed out

    ??? i had : /etc/pure-ftpd/conf/PassivePortRange , /etc/pure-ftpd/conf/ForcePassiveIP ...

    But , can i stop this old ftp and only allow SSH ? (SFTP)
    then the question is : is chroot ssh (jailkit) and ftp connect use the same fodler ?
     
    Last edited: Aug 24, 2020
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The error means that you did not open the passive port range in your firewall. If it would be open, then you won't get a timeout.
     
    ledufakademy likes this.
  3. Jesse Norell

    Jesse Norell ISPConfig Developer ISPConfig Developer

    @till said how to fix it, but yes, you can disable the ftp server and close those ports in your firewall.
    Yes, both default to the same directory, and the location for an account of either type can be changed under the Options tab by an admin.
     
    ledufakademy likes this.
  4. ledufakademy

    ledufakademy Member

    yep, good advice, again ...
    thank you.

    raahhh : those range port ftp , so old for me !!! (i"m old ...bouahhhhh)
     
    Last edited: Aug 25, 2020

Share This Page