FTP went down stangley

Discussion in 'Installation/Configuration' started by plmcomputerservices, Mar 31, 2011.

  1. plmcomputerservices

    plmcomputerservices New Member

    I have just finished the perfect server installation of ISPConfig3 and everything was working beautifully. This is my third installation after having some minor FTP errors on the first install but I made sure to follow the instructions perfectly minus the Quota part as I don't believe I need that for my server.

    I just set up a website on a subdomain meant for uploading IP cam recordings and it was working fine for a day. I checked everything and saw that the files were successfully FTPing to the server.

    After a day, I noticed that another site with a previously working ftp user no longer had the ability to write to it the directories though it could still read.

    I realized that the only this that has changed in that time is the creation of the subdomain site and the new FTP user meant for the IP camera. Then I realized that none of the my users could write to their directories though they seem to be given the proper privileges to their respective directories.

    The cliffhanger is that the directory that once contained the Camera's ftp'd data is now gone! I can only write to a directory if I chmod it 777. This isn't the best practice.

    Any thought's on why this happened or how to fix it? Seriously, I have made no changes to the server outside of the creation of the site and ftp user and then giving the camera permission to upload data upon motion detection... In looking at my servers quota I see that the camera did not upload video for very long as I have used barely any bandwidth....
     
  2. till

    till Super Moderator

    Please make sure that you use php-cgi or php-fcgi in the website settings and that the suexec checkbox is enabled, so that scripts and FTP use the same uid. Without that setting, you get read only access to the files.
     
  3. plmcomputerservices

    plmcomputerservices New Member

    Okay, I enabled suexec on the site and recreated the ftp user and it worked. I had to recreated the user for it to work.

    I will say that I tried this as I read this in another forum before posting. It worked initially but did not work later for some reason.

    If you don't here back from me, then the fix stuck. Thank you. I'm going to go grab some sleep.. I had a 2 hour nap in the last 48 hours and I'm starting to feel like I'm loosing my edge...
     
  4. plmcomputerservices

    plmcomputerservices New Member

    Thank you.

    Okay, I enabled suexec on the site and recreated the ftp user and it worked. I had to recreated the user for it to work.

    I will say that I tried this as I read this in another forum before posting. It worked initially but did not work later for some reason.

    If you don't here back from me, then the fix stuck. Thank you. I'm going to go grab some sleep.. I had a 2 hour nap in the last 48 hours and I'm starting to feel like I'm loosing my edge...
     
: ftp, ispconfig3

Share This Page