FTP user with folder limit

Discussion in 'General' started by MaTheRyS, Nov 5, 2009.

  1. MaTheRyS

    MaTheRyS New Member

    [solved] FTP user with folder limit


    I've just installed ISP config 3 and i have a little problem.

    I have the domaine mempa.org.
    I've done a subdomain metin2sg-fr.mempa.org with L redirection type.
    subdomain is in /var/www/clients/client4/web4/web/metin2sg

    I would like to have a ftp account that can just acces to the folder where is the subdomain.
    If i create the ftp account from the normal user, i can't specify folder but i saw that from admin account, i can specify in the options :
    Directory : /var/www/clients/client4/web4
    That i have replaced by :
    Directory : /var/www/clients/client4/web4/metin2sg

    All seems ok but when i try to connect to the ftp with this account, this is not possible. All ftp clients say to me : deconnected / not possible to connect

    Etat :	Connexion à ftp.mempa.org ...
    Etat :	Connecté à ftp.mempa.org. Attente du message d'accueil...
    Réponse :	220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Réponse :	220-You are user number 2 of 50 allowed.
    Réponse :	220-Local time is now 21:55. Server port: 21.
    Réponse :	220-This is a private system - No anonymous login
    Réponse :	220 You will be disconnected after 15 minutes of inactivity.
    Commande :	USER mempametin2sg
    Réponse :	331 User mempametin2sg OK. Password required
    Commande :	PASS ********
    Erreur :	Déconnecté du serveur
    Erreur :	Impossible de se connecter !
    So what could i do to fix this ?
    And why only admin account can change the directory directive in the option of the ftp account ?

    Thanks. (sorry for my bad english)
    Last edited: Nov 7, 2009
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    And you were able to connect with this FTP account before you changed the path manually?
  3. MaTheRyS

    MaTheRyS New Member


    And if i get back the directory option to the defaut value :
    It's working too.
  4. giftsnake

    giftsnake New Member

    compare the permissions of the two different folders
  5. MaTheRyS

    MaTheRyS New Member

    /var/www/clients/client4/web4 -> 0755 owner root

    /var/www/clients/client4/web4/metin2sg -> 0755 owner web4
  6. giftsnake

    giftsnake New Member

    you forgot the .../web/... or added it somewhere
    Last edited: Nov 6, 2009
  7. MaTheRyS

    MaTheRyS New Member

    Oops, sorry, yes it was my fault !

    I put /var/www/clients/client4/web4/metin2sg
    instead of /var/www/clients/client4/web4/web/metin2sg

    Now it's working much better :D

    Thanks a lot :)
    Last edited: Nov 7, 2009

Share This Page