FTP-User: WARNING - User dir is outside of docroot. ISPConfig 3.0.4.6

Discussion in 'General' started by cat1510, Feb 7, 2013.

  1. cat1510

    cat1510 New Member

    Hi folks,

    I have a strange thing.
    After update to 3.0.4.6 I'm not able to change the ftp user path to a new one, which not already exists.
    As you can see in the ISPConfig Log it says: Creating now!
    But that isnt working...?!?!
    If I create the folder by myself from console the access works fine.


    Code:
    /usr/local/ispconfig/server/server.sh                                               (2013-02-07 13:41:56)
    07.02.2013-12:42 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    07.02.2013-12:42 - DEBUG - Found 1 changes, starting update process.
    07.02.2013-12:42 - DEBUG - Calling function 'update' from plugin 'ftpuser_base_plugin' raised by event 'ftp_user_update'.
    07.02.2013-12:42 - DEBUG - FTP User directory '/var/www/clients/client2/web6/ftpuser/cat1511' does not exist. Creating it now.
    07.02.2013-12:42 - WARNING - User dir is outside of docroot.
    07.02.2013-12:42 - DEBUG - Processed datalog_id 893
    07.02.2013-12:42 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished.
    
    I already checked the plugin plugins-available/ftpuser_base_plugin.inc.php but I can't any mistake.
    The second thing I tried to add the path: /var/www/clients/client2/web6/ftpuser/ to OpenBaseDir
    for this website. That hasn't any effect.

    Someone has a suggestion how to fix it?


    CAT
     
  2. cat1510

    cat1510 New Member

    No Idea @ this topic?
     
  3. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Did you search the bugtracker if this issue is known or has been fixed already? If it was not in the bugtracker, did you add it and got a response if this bug was verified and fixed?

    Did you add it to the open basedir field in the correct way, separated by : and did you add it in the correct website and not globally?
     
  4. cat1510

    cat1510 New Member

    Sorry I never searched for that. :(
    Where can I find?




    Yes I did. In the Options of the WebSite, not Globally. And of course I used : to separate them. I read a lot before including Your great Manual.
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    http://bugtracker.ispconfig.org/

    OK. Then you can check the open_basedir path by createing a php file with phpinfo(); You path should be listed there.
     
  6. cat1510

    cat1510 New Member

    /var/www/clients/client2/web6/web:/var/www/clients/client2/web6/ftpuser:

    The problem is only to create the dir.
    But that isnt working...?!?!
    If I create the folder by myself from console the access works fine.
     

Share This Page