FTP user panel issue

Discussion in 'Installation/Configuration' started by Captain, Aug 22, 2013.

  1. Captain

    Captain Member


    I find one issue in Web Access - FTP-Accounts - FTP User panel, when I open ftp user details go to tab Options and after that to FTP User tab I have Error:
    "You have no permission for this domain."
    It hapens in all ftp account. I try login by admin, and also as domain holder. The same error.

    I have ISPConfig, Ubuntu 12.04.3 LTS

    How to solve it?

    Thank you.
  2. McLure

    McLure New Member

    Same error here one one Web Site - and ftp

    Waked up Friday to a messed server.
    Repair of symlink in /var/www fixed the web site, but not solved FTP.
    Is it correct with root:root permission on symlink's
    here: /var/www/clients/client1

    Will - Reconfigure Services? (yes,no) [yes]:
    in the "ispconfig_update.sh" script harm something?
    Will it rewrite permission etc based on information in the "dbispconfig.sql"
    Last edited: Aug 24, 2013
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. They ahve to be owned by root.

    It will update the configuration files of all services to work with the new ispconfig version. If you modified them manually, your manual changes will be removed.

    Permisions of config files: yes. Permissions of websites: no. Prmissions of websites are not changed by a ispconfig update anyway.
  4. Captain

    Captain Member

    How to solve the problem with FTP User panel? Permisions seems that correct.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    @captain: thats reported in the bugtracker and fixed already in svn for some time.

    If you dont want to wait for the release, then you can fix it by unpacking and then uploading the ttached file to /usr/local/ispconfig/interface/web/sites/

    Attached Files:

  6. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

  7. pinky

    pinky New Member

    If you get an issue where the ftp edit panel doesnt open check that the file in /interfaces/web/ has the correct file permissions.

    for some reason mine was set to root:root instead of ispconfig:ispconfig

Share This Page