ftp user does not have write permissions to website

Discussion in 'Installation/Configuration' started by vondie, Dec 13, 2017.

  1. vondie

    vondie New Member

    I have to preface, I'm not a Linux expert so please forgive me if my wording is confusing or completely off base.

    We have a running ISPConfig 3.1.3 environment on CentOS 7.3. Up to this point, any updates or file changes have been made using the joomla front end. We have a need to made a larger update to our downloads section so I wanted to ftp in using FileZilla and noticed that I cannot delete or upload files via the defaultadmin ftp user we created under ISPConfig. We only have read access. Reading other threads here, I have found that the owner and group for the folders are not consistent with what it should be using ISPConfig. This is what the files look like right now:

    [[email protected] web]# ls -la
    total 124
    drwxrwxrwx 24 web1 client0 4096 Jun 15 10:09 .
    drwxr-xr-x 9 root root 94 Jun 5 2017 ..
    drwxr-xr-x 11 apache apache 170 Aug 31 08:58 administrator
    drwxr-xr-x 3 apache apache 49 Jun 15 10:05 backups
    drwxr-xr-x 2 apache apache 44 Jun 15 10:05 bin
    drwxr-xr-x 5 apache apache 4096 Jun 15 10:04 blog
    drwxr-xr-x 4 apache apache 56 Oct 20 08:09 cache
    drwxr-xr-x 2 apache apache 119 Jun 15 10:04 cli
    drwxr-xr-x 40 apache apache 4096 Jun 15 10:04 components

    I have also read that that the owner and group should be web1:client0 so I ran Chown -R web1:client0 /var/www/clients/client0/web1/web. The owner and group now look good, but doing this breaks the website. I checked the users for the client0 group and see apache as part of that group:

    [[email protected] web]# grep 'client0' /etc/group
    client0:x:5005:apache

    Any help would be greatly appreciated!
    Tim
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The files should be owned by web1:client0 indeed and not apache. Whch PHP mode do you use and is suexec on in that site? PHP mode should be php-fcgi or php-fpm and the suexec checkbox should be enabled.

    and which exact error do you get in the website error.log file now?
     
  3. vondie

    vondie New Member

    Thank you for the quick reply.

    PHP is set to Mod-PHP
    SuEXEC is checked

    What is the location for the error.log file?
     
  4. vondie

    vondie New Member

    I have changed PHP to PHP-FPM and performed the chown as suggested, leaving SuEXEC checked. The website now is responding with an ERROR 503 - Service Unavailable!
     
  5. durchd8.de

    durchd8.de Member

    Maybe you have SELinux enabled still?
    What is the output of
    Code:
    sestatus
    ?
     
  6. vondie

    vondie New Member

    SELinux Status: disabled
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    That's probably the reason for the wrong apache permissions of the files.
    Try to switch to php-fcgi instead of php-fpm.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The log folder f the website.
     
  9. vondie

    vondie New Member

    Just to be sure, the drop down choices I see do not have php-fcgi, but is does have Fast-CGI. Are the two really the same?
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    yes, that' the same
     
    vondie likes this.
  11. vondie

    vondie New Member

    Thank you so much for your help till. Changing to Fast-CGI and changing the ownership seems to be working. Very grateful for support.
     

Share This Page