ftp user auth fails - root fine

Discussion in 'Installation/Configuration' started by scwhite, Jun 29, 2012.

  1. scwhite

    scwhite New Member

    I've searched the forum but seems to be similar but different. I can connect fine to server via ftp with root but when I add a user it failes on authentication. I have checked the ftp_user data base and it is recording the new user and I am using the right user (prefix too) and pass. I have tried with numberer IP and alias (both ping) and it connects bothw ways but fails authentication. I'm on centos and didnt get any errors when I set up pureFTP.
     
  2. cfoe

    cfoe ISPConfig Developer

    you shouldn't be able to connect by the "root" user.
    Please check if your pure-ftpd is retrieving the users from the mysql database.

    In your case it sounds like you are connecting with the unix user "root".
     
  3. scwhite

    scwhite New Member

    I setup a ftp user in the panel and then tried to use that account and no, pureFTP does not appear to be using the MySQL table. The panel is because any and all changes made in the panel are saving in MySQL fine.

    I have s-canned centOS altogether and will be redoing it tonight using your Debian tutorial which will make my install match the manual and it will be using your recommended flavor of Linux.
     
    Last edited: Jul 2, 2012

Share This Page