FTP upload Problem

Discussion in 'Installation/Configuration' started by teves, Mar 12, 2007.

  1. teves

    teves Member

    Hi,

    I have one annoying problem on my Suse 10.1 / ISPConfig 2.28 Webserver.
    Whenever you upload a site via ftp (using the web administrator's username), the file permissions on the server are wrong afterwards; the site can not be viewed in the browser.
    To me personally, this is not a problem, I can connect to the server via putty and change the permissions manually after uploading.
    But my clients do complain about it.
    What can I do about it? Is this a ftp server configuration issue?

    regards,
    Tom
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. You can set the default permissions for uploaded files in the proftpd.conf file (if you use proftpd).
     
  3. teves

    teves Member

    Hello Till,

    no, I'm using vsftpd.
    I have already set the 'local_umask' value to 022 (and to other values after that). After that I always restarted vsftpd and made a new ftp connection, but the permissions on the server are always 0600 when I upload something.
    Am I missing something? Any ideas?

    Thank you,
    regards,
    Tom
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ? What's in /etc/vsftpd.conf?
     
  5. teves

    teves Member

    Hello,

    the problem is solved now, though I don't know why.
    It suddenly worked without me changing anything. (Yeah I know, everyone tells you so, though it normaly doesn't work after changing nothing... :D )

    Thanks for your help anyway!

    regards,
    Tom
     

Share This Page