FTP TLS enabled but no extenral connection

Discussion in 'Installation/Configuration' started by razor7, Jun 28, 2013.

  1. razor7

    razor7 Member

    Hi, if I try to connect to FTP from WAN using Explicit TLS, FileZilla times out and an error is thrown.

    Is there anything I can do to fix it?

  2. tecnoplaga

    tecnoplaga New Member

    I think it's a firewall issue, disable it and test.

    implicit TLS uses ports 990 and 980

    If CentOS 6 + you can disable it on:

    # System-config-firewall-tui
  3. razor7

    razor7 Member

    Hi, thanks a lot!, I have enabled ports 980 and 990 in ISPConfig Firewall through System->Firewall option but no luck, still can't access FTP server remotely using implicit TLS nor ecxplicit!

    I'm using Ubuntu server 12.04 LTS.

    Thanks in advise!

    EDIT: syslog file says that explicit FTP over SSL/TLS was ok, but FileZilla got the same timeout error

    Last edited: Jul 1, 2013
  4. tecnoplaga

    tecnoplaga New Member

    I had the same problem and to find the error, temporarily disable the firewall, then I could see the necessary ports.

    # sudo ufw disable
  5. razor7

    razor7 Member

    Bingo! in order to solve my problem, I had to configure passive ports in file /etc/pure-ftpd/conf/PassivePortRange, this way.
    Then entered port range 50000 50050 (without any colon) and rebooted pure-ftpd

    Then, in my NAT router, I have set the port range 50000-50050 to point to the LAN server IP.

    That did the trick for me.

    Best regards!
    Last edited: Jul 2, 2013

Share This Page