FTP time-out

Discussion in 'Installation/Configuration' started by jorizzzz, Oct 1, 2007.

  1. jorizzzz

    jorizzzz New Member

    I've got another problem with my new installation. I'm using Proftpd as FTP service and all is working well. But when i try to upload a large amount of files, it gives me a time-out connection...

    This is my current proftpd configuration file:
    Code:
    ServerName                      "Debian"
    ServerType                      standalone
    DeferWelcome                    off
    
    MultilineRFC2228                on
    DefaultServer                   on
    ShowSymlinks                    on
    UseReverseDNS                   off
    TimeoutNoTransfer               600
    TimeoutStalled                  600
    TimeoutIdle                     1200
    
    DisplayLogin                    welcome.msg
    DisplayFirstChdir               .message
    ListOptions                     "-l"
    
    DenyFilter                      \*.*/
    
    DefaultRoot ~
    IdentLookups off
    ServerIdent on                  "Younghosting FTP Server."
    
    
    # Uncomment this if you are using NIS or LDAP to retrieve passwords:
    #PersistentPasswd               off
    
    # Uncomment this if you would use TLS module:
    #TLSEngine                      on
    
    # Uncomment this if you would use quota module:
    #Quotas                         on
    
    # Uncomment this if you would use ratio module:
    #Ratios                         on
    
    # Port 21 is the standard FTP port.
    Port                            21
    
    # To prevent DoS attacks, set the maximum number of child processes
    # to 30.  If you need to allow more than 30 concurrent connections
    # at once, simply increase this value.  Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd)
    MaxInstances                    30
    
    # Set the user and group that the server normally runs at.
    User                            nobody
    Group                           nogroup
    
    # Umask 022 is a good standard umask to prevent new files and dirs
    # (second parm) from being group and world writable.
    Umask                           022  022
    # Normally, we want files to be overwriteable.
    AllowOverwrite                  on
    
    # Delay engine reduces impact of the so-called Timing Attack described in
    # http://security.lss.hr/index.php?page=details&ID=LSS-2004-10-02
    # It is on by default.
    DelayEngine                     on
    
    Include /etc/proftpd_ispconfig.conf
    
    One other thing, do i need to enable the quota module in here?


    Thanks alot!
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Do you have the exact error message?
     
  3. jorizzzz

    jorizzzz New Member

    Nope sorry, it just gives me a time-out error...
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Is there no error message in your logs?
    Have you tried both active and passive transfers in your FTP client?
     

Share This Page