ftp/ssh users can't log in - ISPConfig 3

Discussion in 'Installation/Configuration' started by zogthegreat, Jun 4, 2010.

  1. zogthegreat

    zogthegreat New Member

    Hi everyone,

    New problem. I am trying to login as a website user using Filezilla. Everytime I try to login I get the following:

    Status: Connecting to 76.XXX.XX.150:21...
    Status: Connection established, waiting for welcome message...
    Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response: 220-You are user number 1 of 50 allowed.
    Response: 220-Local time is now 09:42. Server port: 21.
    Response: 220-IPv6 connections are also welcome on this server.
    Response: 220 You will be disconnected after 15 minutes of inactivity.
    Command: USER web1_bill
    Response: 331 User web1_bill OK. Password required
    Command: PASS ********
    Response: 530 Login authentication failed
    Error: Critical error
    Error: Could not connect to server

    I have done the following:

    recreated the password about 20 times
    Deleted and recreated FPT users in the control panel.
    Uninstalled and reinstalled pure-ftp
    restarted the fpt service numerous times
    Tried to do as suggested here: http://www.faqforge.com/linux/contr...nable-debugging-in-pure-ftpd-on-debian-linux/, got the following output:
    [root@server1 pure-ftpd]# tail -n 100 /var/log/syslog
    tail: cannot open `/var/log/syslog' for reading: No such file or directory

    (I am using CentOs, so I think it is a different system command, googling it now).

    Here is the output of netstat -tap | grep ftp

    [root@server1 log]# netstat -tap | grep ftp
    tcp 0 0 *:ftp *:* LISTEN 2460/pure-ftpd (SER
    tcp 0 0 localhost.localdomain:ftp localhost.localdomain:50864 TIME_WAIT -
    tcp 0 0 *:ftp *:* LISTEN 2460/pure-ftpd (SER

    I gave up in furstration, an decided to just use ssh. I enabled ssh shell-user in the control panel. However, got the following:

    [bill@phoenix ~]$ ssh [email protected]
    [email protected]'s password:
    Permission denied, please try again.

    To me, it seams I have a problem with passwords or permissions.

    Does anyone have any suggestions?

    Thanks

    zog
     
  2. Nicram

    Nicram New Member

    Remember to use fyull name form ISPConfig.
    for example user added by administrator got default on the beggining.
    Like if i add user "nicram" then i must use defaultnicram as ftp login name.
    If You got clients and they use some name then this name i also used. for example i have added new client "jack" and he add new ftp account "me".
    Then he need to use jackme as ftp username.
    Same with ssh i think.
     
  3. khoanv

    khoanv New Member

    In my case, just restart the server, everything works like a charm.
     

Share This Page