FTP slow after move

Discussion in 'General' started by happz, Jul 3, 2008.

  1. happz

    happz Member

    Question. Any ideas why I get VERY slow FTP sessions and pretty much unable to upload or download via ftp client filezilla after i move and changed from cable modem to dsl modem? My sites come up fine and ispconfig seems okay but ftp to site and it take much longer to log in and my opens won't open for like 3 or 4 minutes when i click to open them. Try to delete and they won't delete....not sure what is going on. no apparent damage to the server from what i can see....

    happz
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried both active and passive transfers in your FTP client?
    Any errors in your logs?
     
  3. happz

    happz Member

    Can you give me the path to where i need to check. Also, i noticed that even logging into SSH (putty) it take about 10 seconds which didn't happen before either. plus now, i am unable to yum update or yum upgrade..you know to centos 5.2...anyway, i will look for response.
    thanks Falko
     
  4. happz

    happz Member

    Falko, here is log from "message"

    Jul 3 10:00:01 server2 proftpd[10481]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session closed.
    Jul 3 10:30:01 server2 proftpd[10927]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session opened.
    Jul 3 10:30:01 server2 proftpd[10927]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session closed.
    Jul 3 10:34:59 server2 /sbin/mingetty[3793]: tty1: invalid character 0x1b in login name
    Jul 3 10:36:32 server2 kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Down
    Jul 3 10:36:36 server2 kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
    Jul 3 11:00:01 server2 proftpd[11371]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session opened.
    Jul 3 11:00:01 server2 proftpd[11371]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session closed.
    Jul 3 11:30:01 server2 proftpd[11819]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session opened.
    Jul 3 11:30:01 server2 proftpd[11819]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session closed.
    Jul 3 12:00:01 server2 proftpd[12274]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session opened.
    Jul 3 12:00:01 server2 proftpd[12274]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session closed.
    Jul 3 12:30:01 server2 proftpd[12722]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session opened.
    Jul 3 12:30:01 server2 proftpd[12722]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session closed.
    Jul 3 13:00:01 server2 proftpd[13168]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session opened.
    Jul 3 13:00:01 server2 proftpd[13168]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session closed.
    Jul 3 13:30:01 server2 proftpd[13630]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session opened.
    Jul 3 13:30:01 server2 proftpd[13630]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session closed.
    Jul 3 14:00:01 server2 proftpd[14094]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session opened.
    Jul 3 14:00:01 server2 proftpd[14094]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session closed.
    Jul 3 14:30:01 server2 proftpd[14561]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session opened.
    Jul 3 14:30:01 server2 proftpd[14561]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session closed.
    Jul 3 15:00:01 server2 proftpd[15008]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session opened.


    NOt sure if this helps...but if you know what path i need to find the log you said you wanted to know about....thanks
     
  5. happz

    happz Member

    don't mean to keep posting to my own question but..

    Falko i read another FTP area and you had them run this so i did...here is the results:

    [[email protected] etc]# /etc/init.d/proftpd restart
    Shutting down proftpd: [ OK ]
    Starting proftpd: - warning: handling possibly truncated configuration data at line 64 of '/etc/proftpd.conf'
    - setting default address to 127.0.0.1
    [ OK ]
    [[email protected] etc]#


    anything from this guys....?

    thanks.

    happz
     
  6. falko

    falko Super Moderator ISPConfig Developer

    You can switch to active/passive mode in your FTP client.
    I think it could have something to do with your router's firewall. Are you using the same router as before?
     
  7. happz

    happz Member

    My equipment is the same but my ISP is not. I was using cable modem and now i'm using DSL and the config in my router is using PPPoE. Before the router had the static IP and now the dsl modem carries the static but hands control to the router. I have tried to change active/passive and there is some improvement but it is still not correct. I can browse around (but slow) and when i tried to upload files.....well, it just doesn't happen. As noted is that when i ssh in it takes much longer now to accept my password....after about 30 sec's it will log me in....

    happz
     
  8. happz

    happz Member

    Update

    Falko...i just remembered i had another server with same config only different IP so i powered down the one in question and brought the other one up. i changed my port forwarding to the IP of the server that is now up and everything works. So I'm going to get a few updates for this server and then bring it down. when i get the server in question that is not working correct and now that we know it is not an ISP issue or router problem, where should i look. I have over 20 domains running from this server so i would like to get it working again. thanks Falko or anyone who can respond.

    happz
     
  9. Theophilus

    Theophilus New Member

    It could be your new ISP is not providing reverse DNS properly. Try adding the IP address assigned to your DSL service to your /etc/hosts file on your server.

    If it speeds the session up, this pinpoints the problem.
     
  10. trexen

    trexen Member

    Do you have port 20 anf 21 open in youre FW for FTP ?
     
  11. happz

    happz Member

    I do

    I have 20, 21, 443, 80, and 81. Is there something else i need to port forward you think?

    happz
     
  12. trexen

    trexen Member

    20/21
    25 smtp
    465 smtps (secure)
    993 imaps (secure)
    995 pop3s (secure)
    143 imap4
    110 pop3
    22 ssh (change to another port /etc/ssh/sshd_config) <-- Debian4 etch

    Rgds
    Marcus
     

Share This Page