FTP/Shell users cannot login

Discussion in 'Installation/Configuration' started by Steen Rabol, Mar 12, 2019.

  1. Steen Rabol

    Steen Rabol New Member

    Hi
    Some background: I have a Linux VPS hosted, 'limited' linux admin knowledge so I installed ISPConfig to 'solve' the trivial things like creating new websites etc. the purpose of my VPS is to host 5-10 websites that is in development and as each site is done it will be moved to another server.

    here is what I have done:
    Installed Ubuntu
    Then used a 'script' (https://github.com/servisys/ispconfig_setup) to install all.
    I then created a client and 1 site, one ftp account and 1 shell account
    in name.com i pointed the DNS to the VPS (ping etc is giving the correct answer)
    FTP user cannot access: tried using FileZilla:
    Code:
    Status:          Resolving address of xxx.xxx.xxx
    Status:          Connecting to xxx.xx.xx.xx:21...
    Status:          Connection established, waiting for welcome message...
    Response:     220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response:     220-You are user number 1 of 50 allowed.
    Response:     220-Local time is now 10:29. Server port: 21.
    Response:     220-This is a private system - No anonymous login
    Response:     220-IPv6 connections are also welcome on this server.
    Response:     220 You will be disconnected after 15 minutes of inactivity.
    Command:    AUTH TLS
    Error:            Connection timed out after 20 seconds of inactivity
    Error:            Could not connect to server
    Shell users cannot login either, getting the error that 'Permission denied'
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    For the shell user, did you use the full username incl. prefix like: "c1myuser" for the login, and not just 'myuser'?
    Regarding FTP, try to connect without TLS, if this works, then you might have a problem with the SSL certificate of the FTP server.
     
  3. Steen Rabol

    Steen Rabol New Member

    Hi
    I do not know what I did, but the shell user can log on now - But... the user can access the whole server and not only 'his' home

    FTP is still the same
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you did not enable jailkit for that user. See Shell user options, you can create a jailed user there and a user without jail. To lock your user to the website, create a jailed user.
     
  5. Jesse Norell

    Jesse Norell Well-Known Member

    It seems like there have been numerous issues with filezilla and recent pure-ftpd (maybe recent gnutls ?), possibly old filezilla clients use too old of TLS or similar? Try testing with a different client; if that works, try updating the client to the latest version, or searching for filezilla issues specifically (maybe you can allow the older/less secure tls versions in pure-ftpd?).
     

Share This Page